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Student Services View 
In MyEdBC, IEPs are written, renewed, and edited within the Student Services View.  Once 
written, IEPs are accessible to classroom teachers, administrators, counsellors etc. in their 
regular (Staff/School) view within MyEdBC (Documents Side Tab > Plans sub-side tab).   

 

1.1 Navigating to Student Services View 
Click on the View menu to change to Student Services View. 

 

 

1.2 Student top tab 
The Student top tab defaults to the Filter ‘Does Not Apply to BC – My Current Cases – All’. 

Change the filter  menu to ‘Active’ to view all students enrolled in the Student Services 
module: 
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Create/Renew an IEP 

1.3 Enroll a Student in the Student Services View (Scenario 1) 
 

If the student is not already enrolled in the Student Services View, you will need to Enroll the 
student.  The Enroll process brings the student into the Student Services View and creates an 
IEP at the same time.   

Student Services View > Student top tab > filter: Active 

1. From the Options menu, select Enroll 

 
 

2. The Enroll window appears.  Fill in the fields as follows: 
● Student - Use the magnifying glass to select the student to enroll and create a 

plan 
● Case Manager - Use the magnifying glass to select the Case Manager 
● Start Date - Enter the IEP Start Date 
● End Date - 30/09/20XX  (30th of Sept of next school year) 

● Plan Name - 73-IEP-20XX    Eg if the school year ends in 2022, use 2022.  
The Version # can be added if you need to create a new version according 
to district standards.   

 
Note this CB-IEP was created for the 2019-2020 school year 

 

3. Click Run 

4. The student is now enrolled, and a BLANK IEP has been created. 
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1.4 Student Does Not Have a Current Active Plan (No Plan Icon ) 
(Scenario 2) 

For example: a student new to our school district 

Student Services View > Student top tab > filter: Active 

1. From the Options menu, select Renew Plan 

 
 

2. The Renew Plan window appears.  Fill in the fields as follows: 
a. Student - Use the magnifying glass to select the student 

i. This is a list of all students who are enrolled in the view. 
b. Plan Selection - if the student had an IEP in MyEdBC last year, you can select it 

here to copy all of the IEP information forward to the new plan.  If the student did 
not have an IEP in MyEdBC last year, you can leave this blank. 

c. Start Date - Enter the IEP Start Date 
d. End Date - 30/09/20XX (30th of Sept of next school year) 
e. Review Date - Date you are next planning to review the IEP 
f. Plan Name - Per the provincial standard, enter the plan name of District Number-

Plan Type-School Year:   

73-IEP-20XX 

 

3. Click Run 

4. A new IEP will be created 

  



6 

1.5 Student Has a Current Active Plan (Has a Plan Alert ) 
(Scenario 3) 

For example: Student changes schools in SD73, a student grade level is changed, or a change 

in designation 

Student Services View > Student top tab > filter: Active 

1.5.1 End Date Current Plan for tomorrow 

Before you can Renew a Plan, you will first need to end date the current plan: 

Student Services view > Student top tab > select student > Plans side tab > click into the 
Details of the student’s Active IEP > Plan Details  

1. End date: Enter tomorrow’s date   
2. Click SAVE 

 

   

Note: If you enter an end date with today’s date or a past date, the student will be exited 
from the Student Services module. If this happens, you can Enroll the student again, refresh 
your screen and then you will be able to renew the plan as outlined below.  
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1.5.2 Renew Current Plan  

Student Services view > Student top tab > Options menu > Renew Plan 

 

The Renew Plan window appears.  Fill in the fields as follows: 

1. Student:  Click the magnifying glass, select the student, click OK  
2. Plan Selection: Click the magnifying glass, select the Plan you wish to renew (copy 

forward), click OK  
Note: if you do not select a plan here a BLANK Plan will be created. 

3. Start Date:  Enter the IEP Start Date as the day after the date you used to end date 
the Active plan (see 2.3.1 above).  Enter the day after tomorrow’s date as the start 
date of the new plan. 

4. End Date:  September 30th of the next school year. 
5. Review Date:  The date in the future you plan on reviewing the IEP. 
6. Plan Name: Per provincial standard, enter the plan name in the following format District 

Number-Plan Type-School Year: 
 

73-IEP-20XX-2 (For example: 73-IEP-2025-2) 

 

7. Click Run. A new IEP will be created.  
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1.5.3 Parent Consultation Checkbox 

Once an IEP has been copied forward, the Parent Consultation checkbox has copied in as 
checked and needs to be unchecked. 

Student Services view > Student top tab > select student > Plans side tab > click into the 
Details of the student’s Draft IEP > Plan Details  

1. Check  ‘the Parent Consulted’ checkbox in the new IEP AND Enter the NEW Parent 
Consultation Date

NOTES: 

• The Parent Consultation Date must be during the current school year. 

• If there is no date entered here, the software looks in the Log for a Parent 
Consultation Date entry. 

• Otherwise, the date will be blank on the Printed/Published IEP. 

 

2. Click Save 
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Write the IEP 
Once a new IEP has been created for the student using the Renew or Enroll process, you can 
access and complete the IEP: 

Student Services View > Student top tab > filter: Active 

1. Place a checkmark next to the student, and click on the Plans side tab:

 

2. Click the hyperlink to access the Plan Details: 

Click on the Dictionary to switch between Legacy IEPs (prior to Sept 2022) and 

Competency Based IEP (Sept 2022 +) 
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1.6 Plans Details 
IEP details are entered into tabs: My Personal Profile, My Learning Profile, Support and Plans, 
Core Competency Goals, Curricular Competency Goals, Student Support Team, and Plan 
Details.   

1.6.1 My Personal Profile 

My Interests, My Learning Preferences, What You Need To Know About Me - have the 
student describe themselves in these cases 

● Location of Evidence1, Location of Evidence2, and Location of Evidence3 - If there 
are videos, pictures or media about the student please indicate where to access them 
and/or include a URL link.  

● Click SAVE if changes have been made. 

 

Tip:  Place your cursor over the blue information circle  for more information. Click the 
‘double boxes’  to open the text window bigger. 
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1.6.2 My Learning Profile 

 

 

● Thoughts from my team - Check this box if the learning profile was completed by the 
team members rather than in the student’s own voice.  

● My Competency Area - Use the drop down to select 
● My Strengths and My Stretches  
● My Focus Area - indicate the competency on which the student is to focus. 
● Click SAVE 

1.6.3 Support and Plans 
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● Supports 

1. Click on the Add button 

2. Choose the support Category (Universal Classroom Supports or Essential 
Supports) by clicking on the drop-down menu 

 

3. Select a value for Support Type 

 

4. Enter the Description 

5. Additional supports can be added by clicking Add again 

6. Select and click Delete to remove a support. 

● Supplementary Plans - Click on the Add button to select the type of plan and enter the 
date. These include:

 

1. SD73 Care Plan 

2. SD73 Safety Plan 

3. SD73 AIP (Annual Instructional Plan) 

4. SD73 Behaviour Plan 

5. SD73 Nursing SSP (Support Services Plan) 

6. SD73 Transition Plan 

● Additional Comments – consult with the district Inclusive Support team if you want to 
add information here. 

● Click SAVE 
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1.6.4 Core Competency Goals 

● 

Core Competency Goals  

1. Click the Add button -- In SD73, write three to five goals. 

2. IMPORTANT:  Enter a Goal Number first - preface the number with CC e.g. 
CC1, CC2, CC3, etc. 

 

3. Select Core Competency Area using the drop-down arrow 

 

4. Core Goals can be selected by clicking the black triangle ◀ in the right-hand 

corner: 
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a. Select the Competency from the drop down: 
 

 
 

b. Select the Competency (Facet) to further narrow down the list. 

 
c. Click to insert the text into the Core Goal field: 

 

d. Add to or edit Core Goal field as required.  Click the black triangle ▶ to hide 

the selection screen again. 
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5. In the Objectives area, click the Add button  

 
 

a. Enter the Number, Objective, and Strategies and click OK. 
Ensure to include your baseline data with a date (Month & Year) 

b. We don’t use the columns: Progress Comment, Progress Proficiency & 
Progress Print in SD73 

 

c. Click Add again to add additional Objectives 
 

 
6. Click OK at the bottom of the window 

 
7. Additional Core Competency Goals can be added by clicking Add again 

 
8. Click SAVE 

 

1.6.5 Curricular Goals (Big Ideas and Curricular Competencies) 
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● Big Ideas -  

1. Use the black triangle ◀ to expand the Area of learning bank. 

2. Choose the Area of Learning and the appropriate Grade Level 
3. Click to insert the Big Idea text into the field 

 

4. Add to or edit the Big Idea field as required.  Use the black triangle ▶to hide the 

selection screen. 
5. Click SAVE at the bottom of the screen. 
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● Curricular Competency Goals 

1. Click the Add button 

2. IMPORTANT:  Enter the Goal Number first - preface the number with CR e.g. 
CR1, CR2, CR3, etc. 

 

3. Enter the Goal Status Indicator (Type of Goal) as Replacement or 

Supplemental 

4. Enter the Teacher Responsible (can be more than one teacher) 

5. Select the Area of Learning from the drop-down menu 

6. Click the black triangle ◀ to access choose the Learning Standard from the 

selection screen. 
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7. Select a Curriculum 

8. Select an Area of Learning 

9. Select a Strand to narrow down the list 

10. Click to insert the text into the Learning Standard field

 
11. Add to or edit the Learning Standard field as required.  Use the black triangle 

▶to hide the selection screen. 

12. Add Objectives 
a. Click the Add button 
b. Enter the Number, Objective, and Strategies (enter instructional resources, 

activities and staff that will aid the student in achieving the objective and 
explain how they will be used) 

c. We don’t use the columns: Progress Comment, Progress Proficiency & 
Progress Print in SD73 

 
d. Click OK 
e. Click Add Again to add additional Objectives. 

 
13. Click OK 
14. Click SAVE 
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1.6.6 Progress Report 

There is no requirement for schools in SD73 to use this functionality of MyEducation BC 
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1.6.7 Student Support Team 

 

1. Click Add to add a support team member.  Members can be selected from a pick 
list or typed in. 
 

2. Click the magnifying glass to select a staff member or contact from a pick list: 

 
a. Select a Team member type: 

i. Student Services Staff - District level staff 
ii. Regular Education Staff - School Level Staff 

● Current teachers only will display the student’s teachers.  
Uncheck this checkbox to access all staff members at your School 

iii. Contact - Student’s contacts 
3. If the team member you are adding is not available to select, you can 

alternatively type directly into the Name field. 
4. Enter the team members Role.  
5. Click Add again to add additional team members.  Only one team member 

should be listed per line. 
6. Click SAVE 

 

Note: Some staff members will have the role of ‘Case Manager’ fill in automatically.  If the 
staff member is not this student’s Case Manager it is important to overwrite this, otherwise 
the words ‘Case Manager’ will display next to the staff member’s name on the printed IEP 
report.  Each Plan can only have one Case Manager. 

e 
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1.6.8 Plan Details 

 

● Name - fills in the student’s name automatically 
● Case Manager - select from the pick list.   

Note: When a student is new to your school, ensure to renew the plan and change the 
case manager.  DO NOT just change the case manager’s name. 

● Status - the IEP Status of Draft, Active, or Previous is determined by the Start date 
and End date. 

● Start Date – defaults to the date the Plan is created. 
● End Date – 30th of September of the next school year. 
● Yearly Review Date – The next date you will be reviewing the IEP 
● Plan Name - Per provincial standard, District Number-Plan Type-School Year: 

73-IEP-20XX 

● Parent Consulted - check this box once the parent/guardian consultation is complete. 
● Parent Consulted Date – select the date during the current school year in which a 

parent was consulted.  A date should be entered prior to the October 30th IEP finalization 
date. 

● Click SAVE. 

  

Note: Once you have entered your name in the Case Manager>Name field, you will be able 
to filter for the students on your caseload by choosing the Filter ‘Students in My Cases – 
Active and Draft’ from the Student top tab. 
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1.7 Electronic Logging of Student Support - Optional 
MyEducation BC can be used to create an electronic version of the Student Services 
Record.Click on the Log top tab > Entry Log side tab 

1. From the Options menu, select Add

 

2. The New Plan Log window will open:

 
● Name - select the student using the magnifying glass 
● Service type - required field.  Use the magnifying glass to select ‘Plan’ 

Date - enter the date 
● IMPORTANT:  Select Event type 

 
● Staff Name – enter your first and last name 

3. Click SAVE 
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Service Log Report 
Once you have completed the Log entry, you can print the IEP Consultation Log Report.  The 
report can be accessed as follows: 

● Log top tab > Plans side tab > Entry Log sub side tab > Reports menu > Quick 
Report > Saved report > Click Finish 
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Print the IEP Report 
Once you have completed writing the IEP you can Run the Competency Based IEP Report.  
The report can be accessed from Reports menu on the following locations: 

● For an Individual Student: Student top tab > Plans side tab > Details sub side tab > 
Reports menu > Competency Based IEP Report 

● For Multiple Students: Plan top tab > select the IEP’s you would like to print > Options 
menu > Show Selected > Reports menu > Competency Based IEP Report 

 

● Students to include - current selection 
● Print Legal Name - unchecked will print usual name, checked will print legal name 
● Sort Results by - select a sort order if printing more than one IEP 
● Print on Both Sides - if printing multiple IEPs this will insert a blank page after IEPs 

with odd numbered pages to allow for double-sided printing. 
● Format - Adobe Acrobat (PDF) 
● Click RUN - this will run a PDF report which can then be printed and/or saved 

 
 
 
Note: It is possible to print all your schools CB IEPs at once.  Contact the MyEd BC Team for 
support with this. 

 

  

Note: The Competency Based IEP Report can also be Run in School View or Staff View 
from the Student top tab > Documents side tab > Plans sub side tab > Details. 

e 
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Publish the IEP Report 
Once you have completed writing the IEP you can publish the Competency Based IEP Report.   

● Individual Students: Student top tab > Plans side tab > Details sub side tab > Reports 
menu > Competency Based IEP Report > Publish Tab 

 

 

 

Note: Once all the CB IEPs are finished for your school; it is possible to publish all  
CB IEPS for parents and guardians to view. 
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Information: Plan Alert 
When a student has an Active plan in MyEdBC, they will automatically get a Plan alert icon 

 

This alert tells other teachers, counsellors, and administrators that this student has an IEP in 
MyEdBC that they will be able view: 

 

In addition, they can click on this icon to view the student’s case manager, designation, and a 
summary of the student’s supports: 

 

 

 


