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1.0 Enrollment in MyEducation BC 

Enrollment in schools in MyEducation BC is how students first get entered into the Student 
Information System. It is also how they will switch schools, or add a cross-enrolled, or 
secondary, school that they may be attending. Enrollment may be done by a Centralized/District 
person, or by a School-level person, based on your district business rules, following virtually the 
same steps. 

There are several baseline Security Roles that have the ability to enroll, cross enroll and 
withdraw students: 

 Clerical – School Admin Assistant 

 Clerical – SIS Admin 

 Clerical – SIS Clerk 

 District Support (Level 1) 

 Registrar 

 School Administrator 

If you are customizing an existing Security Role, or creating your own, you will want to ensure 
that role has Create, Read and Update permissions on the Student Enrollment and Student 
School Association tables, in order for them to be able to do Admissions, Withdrawals and 
Cross-enrollments. If you want someone to only be able to see what schools a student has been 
admitted or withdrawn from, you will only need to give them Read permission on that table. 

For Home School Transfer – the act of transferring a student from one Primary school to 
another – can only be performed by a District Support (Level 1) security role. See more in 
Section 4.0 Home School Transfer in this document. 

 

1.1 District Registrar 

Registration by a District-level Registrar will likely be given the Registrar baseline Security 
Role, or a customized version of that. In order for the Centralized registrar to be able to access 
all schools, you will need to make sure that they are Associated to all schools in your district, 
and have an enabled User Account created for them. 

Refer to section 1.4.1.3: Maintaining Secondary School associations for staff in the Security 
Management document for steps on how to associate your staff member with all schools (or a 
group of schools) in your School District. 

When a student needs to be enrolled into a school in your district, your central registrar can log 
in to MyEducation BC and from the School view, click the Select School in the Settings Bar 
and choose their school from the pick list: 

 

Once they are in the School they need to perform their registration tasks, they can follow the 
same steps as the School Registrar. 



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 6 

1.2 School Registrar 

Registration duties at a School are done from the Student top tab. Here, you can Enroll, 
Withdraw, Cross-Enroll, Change Enrollment Status or Change Year of Graduation (YOG). 

Security Roles for a School-level person can be any of the following baseline roles, or a 
customized version: 

 Clerical – School Admin Assistant 

 Clerical – SIS Admin 

 Clerical – SIS Clerk 

 District Support (Level 1) 

 Registrar 

 School Administrator 

For a Customized or newly-created Security role, ensure that the role has Create, Read and 
Update permissions on the Student Enrollment and Student School Association tables. You 
will also want to ensure that you have not removed the Enrollment or Schools side tabs under 
the Student top tab. 

2.0 Admitting/Withdrawing Students 

The following sections will instruct how to admit or withdraw students.  The process used 
depends on the individual student.  Is the student new to the MyEducation BC system? Is the 
student in MyEducation BC and new to your school or district? Was the student previously in 
MyEducation and now archived? Is the student related to students that are already in your 
school?  The answers to these questions determine which process to use. 

2.1 Admitting Students in a School 

2.1.1 Admitting new students 

You will likely be admitting new students to the system when they are entering at a young age – 
Early Learning Centres or Kindergarten, for example – or moving from a non-MyEducation BC 
district or out of Province school. This shows you how to enroll a student into their Primary 
School. That is, this will be their main school that they will be attending (either in person or 
remotely). To enroll a student into the school as a Secondary Student, or Cross-Enrolled, see 
Section 3.0 Cross-Enrolling Students. 

To ensure that your student is actually new, the system will do a restrictive query against all 
students in the province who are currently in MyEducation BC. This will ensure that a duplicate 
record is not created in the event that the student has previously been admitted, as well as 
whether the student is currently active in another school and needs to be withdrawn before 
continuing. If a student meets the archive criteria, check the Archive environment and flag the 
student for retrieval if the student is found there. Once you have established that this is in fact a 
new student, you can carry on to the next step and fill in the information in the wizard. 

To admit a new student, you will be in the School view, on the Student top tab, looking at your 
school’s Student List. Then, follow these steps: 

1. Click the Options menu, and select Registration, followed by Register Student. 
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2. This will bring up the Student Registration wizard 

a) For Step 1, put in the Legal last name along with Gender and Date of birth into 
the corresponding fields. If this student has a family member in your school, you 
will click the “New family member” checkbox, otherwise leave it blank. If this is a 
family member, go to section 2.1.4 – Admitting related students in this document. 
Clicking the Next button will perform the restrictive query to see if this student is 
currently in the system. 

 

b) If a possible match is found, you will see a pop up with any student who fits the 
entered data (birth date within 45 days of the one you entered) and the following 
message: 

 

c) If a match isn’t found and the student meets the archive criteria (see Section 
2.1.3), click the Options menu, and select Flag Student for Retrieval, enter the 
student PEN - or – Legal First Name, Legal Last Name, Gender and DOB. 

If none of the names from Step 1 correspond with your student, and your student 
is not found in the archive, click the Cancel button and move to step 2 of the 
wizard. 

d) For Step 2, you can fill out any additional information you know about this 
student, including the various phone numbers, physical and mailing addresses, 
what Homeroom they will go in, their Home Language and what Calendar in the 
school they will be attached to. If you do not know any of this information, you 
can skip it and add that in later. 

Most schools have only one calendar attached to the student, so you should add 
it here. 

e) In Step 3, you will enter in the student’s Year of Graduation, Enrollment Status, 
Date of entry into the system and Admission code and reason. The first three 
items listed are mandatory. 

Note: Ensure you are typing the correct date format in the Date of birth field. 
If you are unsure what format you are using, you can type in the actual 
month in full and it will convert to the proper format (i.e., “January 10, 2010” 
or “Jan 10 2010” would change to either 10/01/2010 or 1/10/2010 depending 
what you have set for your Locale in your Set Preferences) 
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Year of Graduation (YOG) is what drives the MyEducation BC system; it 
calculates Grade Level based on that number, so be sure you are putting in the 
correct value. It can be adjusted later if the information is put in wrong, but it may 
require someone with a higher security privilege than you have. You will see the 
Grade Level field automatically populated when the YOG is entered and you go 
to another field. If it is incorrect, you can change it now with no ill effect. 

Enrollment Status will generally be set to Active for students who will be going to 
classes on the date you enter in the Date field below. PreReg is set for students 
who will be coming next year, and is the preferred Status for those enrollments. 
This way they can be found easier in the Student List by applying the PreReg 
filter. 

Grade sub level is a specific set of grades other than the numeric Grades 1 
through 12, KF for Kindergarten and EL for Early Learning. For example, if you 
had a student who was only half day Kindergarten, you would set their YOG to 
put them in KF, and then set their Grade sub level to KH. 

For SU, GA or AD, enter the YOG for a grade 12 student this year, and then use 
the appropriate sub grade between those three. 

For EU, HS or AN, enter the most appropriate YOG and then the corresponding 
sub grade level between those three. 

f) In Step 4, you can confirm the full name and that you are enrolling the student in 
the correct school, and then click “Finish”. 

g) When the wizard closes, you will be taken to the Demographics/Details page for 
the Student you just enrolled. If you are taken to a different student, it is because 
the newly registered student would not have appeared on the Student List under 
the existing filter. If your filter was set to Primary Active Students, for example, 
and you set the status of your new student as PreReg, the student would not 
appear in the Student List, and you would have to change the filter to find them.  

 

For more about the information on the Student Details page, see Section 6.0 – Student 
Demographics in this document. 

2.1.2 Admitting existing students 

When enrolling a student, you may be admitting someone whose student record already exists 
in MyEducation BC and now is transferring to your school from a different school. MyEducation 
BC will perform a restrictive query against all students in the province to find the appropriate 
student so that you can bring them into your school. Additionally, if the student meets the 
archive criteria, click the Options menu, and select Flag Student for Retrieval, enter the 
student PEN - or – Legal First Name, Legal Last Name, Gender and DOB see Section 2.1.3 
Admitting a student from the Archive Environment.   

This is only for students who will primarily be going to your school. If you are looking at Cross-
Enrolling a student to your school, see Section 3.0 – Cross-Enrolling Students.  

Tip: set your filter to All Students before registering new students into your 
school, and you will always have them open up to the Details page of your 
newly registered student. 
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To admit an existing student, you will be in the School view, on the Student top tab, looking at 
your school’s Student List. Then, follow these steps: 

1. Click the Options menu, and select Registration, followed by Register Student. 

 

2. This will bring up the Student Registration wizard 

a. For Step 1, put in the Legal last name along with Gender and Date of birth into 
the corresponding fields. If this student has a family member in your school, you 
will click the “New family member” checkbox, otherwise leave it blank. If this is a 
family member, go to section 2.1.3 – Admitting related students in this document. 
Clicking the Next button will perform the restrictive query to see if this student is 
currently in the system. 

 

b. If a possible match is found, you will see a pop up with any student who fits the 
entered data (birth date within 45 days of the one you entered) and the following 
message: 

 

Click the radio button beside the correct student you wish to enroll in your school, 
followed by the OK button. This will enter in all pertinent information into the 
following steps of the wizard, which you can correct if necessary, as well as the 
information in the Student Details page. Click the Next button to move to the next 
step. 

If a student was expelled from your school, you will get the following error 
message when trying to re-enroll them: 

 

Note: Ensure you are typing the correct date format in the Date of birth field. 
If you are unsure what format you are using, you can type in the actual 
month in full and it will convert to the proper format (i.e., “January 10, 2010” 
or “Jan 10 2010” would change to either 10/01/2010 or 1/10/2010 depending 
what you have set for your Locale in your Set Preferences) 



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 10 

This will affect anyone who does not have the permission “Override 
enrollment restrictions” checked. Baseline roles that have this permission 
are: 

 Clerical – School Admin Assistant 

 District Support (Level 1) 

 Registrar 

 School Administrator 

The above users will see this message instead: 

 

Clicking Continue will continue with the enrollment. 

c. For Step 2, you can fill out any additional information you know about this 
student, including the various phone numbers, physical and mailing addresses, 
what Homeroom they will go in, their Home Language and what Calendar in the 
school they will be attached to. If you do not know any of this information, you 
can skip it and add that in later. 

Most schools have only one calendar attached to the student, so you should add 
it here. 

d. In Step 3, you will enter in the student’s Year of Graduation, Enrollment Status, 
Date of entry into the system and Admission code and reason. The first three 
items listed are mandatory. 

Year of Graduation (YOG) is what drives the MyEducation BC system; it 
calculates Grade Level based on that number, so be sure you are putting in the 
correct value. It can be adjusted later if the information is put in wrong, but it may 
require someone with a higher security privilege than you have. You will see the 
Grade Level field automatically populated when the YOG is entered and you go 
to another field. If it is incorrect, you can change it now with no ill effect. 

Enrollment Status will generally be set to Active for students who will be going to 
classes on the date you enter in the Date field below. PreReg is set for students 
who will be coming next year, and is the preferred Status for future enrollments. 
This way they can be found easier in the Student List by applying the PreReg 
filter. 

Grade sub level is a specific set of grades other than the numeric Grades 1 
through 12, KF for Kindergarten and EL for Early Learning. For example, if you 
had a student who was only half day Kindergarten, you would set their YOG to 
put them in KF, and then set their Grade sub level to KH. 

For SU, GA or AD, enter the YOG for a grade 12 student this year, and then use 
the appropriate sub grade between those three. 

For EU, HS or AN, enter the most appropriate YOG and then the corresponding 
sub grade level between those three. 
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e. In Step 4, you can confirm the full name and that you are enrolling the student in 
the correct school, and then click “Finish”. 

f. When the wizard closes, you will be taken to the Demographics/Details page for 
the Student you just enrolled. If you are taken to a different student, it is because 
the newly registered student would not have appeared on the Student List under 
the existing filter. If your filter was set to Primary Active Students, for example, 
and you set the status of your new student as PreReg, the student would not 
appear in the Student List, and you would have to change the filter to find them.  

 

For more about the information on the Student Details page, see Section 6.0 – Student 
Demographics in this document. You may not have to adjust anything for the newly registered 
student’s demographics, if the previous school has kept them up to date. 

 

2.1.3 Admitting a student from the Archive Environment 

The archive process moves eligible student records from Production into the Archive database.  
The student may be retrieved from the Archive database and returned to Production through an 
overnight process similar to the PEN request.   

 
Retrieving a student from the Archive environment and returning their record to Production is a 
part of the standard registration process.  An additional step of Flag Student for Retrieval can 
be done if the student is not found with the restricted query in Production and the student fits the 
archive criteria.  Student archive criteria are:  more than 6 years of age -and- withdrawn 
(inactive) for more than 4 years.   

1. Click the Options menu, and select Registration, followed by Register Student. 

a.  

2. This will bring up the Student Registration wizard 

a. For Step 1, put in the Legal last name along with Gender and Date of birth into 
the corresponding fields. If this student has a family member in your school, you 
will click the “New family member” checkbox, otherwise leave it blank. If this is a 
family member, go to section 2.1.3 – Admitting related students in this document. 
Clicking the Next button will perform the restrictive query to see if this student is 
currently in the system. 

Tip: set your filter to All Students before registering new students into your 
school, and you will always have them open up to the Details page of your 
newly registered student. 



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 12 

3. If the student meets the archive criteria, click the Options menu, and select Flag 
Student for Retrieval, enter the student PEN - or – Legal First Name, Legal Last 
Name, Gender and DOB. 

 

 

When the student is flagged for retrieval, the overnight process will bring the student 
back into Production in the same state they were when archived.  The following day the 
school will follow the registration process in 2.1.2 to complete the process 

 

2.1.4 Admitting related students/siblings 

1. Click the Options menu, and select Registration, followed by Register Student. 

 

2. This will bring up the Student Registration wizard 

a. For Step 1, put in the Legal last name along with Gender and Date of birth into 
the corresponding fields. When a student you are enrolling is related to another 
student in the Province, click Search for related student and a box with additional 
search fields appears. You are required to fill out 2 of the following 3 fields: Home 
phone, Legal last name and Address. Click Search to find the sibling already in 
MyEducation BC. 
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The Student Pick List appears. Find the related student and click OK. Then, 
select the Relationship to the student you are registering (such as sibling). 

 

b. Once you have established the sibling, clicking the Next button will perform the 
restrictive query to see if the student you are enrolling is currently in the system. 

 

c. If a possible match is found, you will see a pop up any student who fits the 
entered data (birth date within 45 days of the one you entered) and the following 
message: 

 

If the student is already in the system, click the radio button beside the student 
you wish to enroll in your school, followed by the OK button. This will enter in all 
pertinent information into the following steps of the wizard, which you can correct 
if necessary, as well as the information in the Student Details page. Click Next to 
move to the next step. If the student is new to MyEducation BC, click Cancel, 
and move to step c below. 

Note: Ensure you are typing the correct date format in the Date of birth field. 
If you are unsure what format you are using, you can type in the actual 
month in full and it will convert to the proper format (i.e., “January 10, 2010” 
or “Jan 10 2010” would change to either 10/01/2010 or 1/10/2010 depending 
what you have set for your Locale in your Set Preferences) 
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If a student was expelled from your school, you will get the following error 
message when trying to re-enroll them: 

 

This will affect anyone who does not have the permission “Override 
enrollment restrictions” checked. Baseline roles that have this permission 
are: 

 Clerical – School Admin Assistant 

 District Support (Level 1) 

 Registrar 

 School Administrator 

The above users will see this message instead: 

 

Clicking Continue will continue with the enrollment. 

d. For Step 2, you can fill out any additional information you know about this 
student, including the various phone numbers, physical and mailing addresses, 
what Homeroom they will go in, their Home Language and what Calendar in the 
school they will be attached to. If you do not know any of this information, you 
can skip it and add that in later. 

Most schools have only one calendar attached to the student, so you should add 
it here. 

e. In Step 3, you will enter in the student’s Year of Graduation, Enrollment Status, 
Date of entry into the system and Admission code and reason. The first three 
items listed are mandatory. 

Year of Graduation (YOG) is what drives the MyEducation BC system; it 
calculates Grade Level based on that number, so be sure you are putting in the 
correct value. It can be adjusted later if the information is put in wrong, but it may 
require someone with a higher security privilege than you have. You will see the 
Grade Level field automatically populated when the YOG is entered and you go 
to another field. If it is incorrect, you can change it now with no ill effect. 

Enrollment Status will generally be set to Active for students who will be going to 
classes on the date you enter in the Date field below. PreReg is set for students 
who will be coming next year, and is the preferred Status for future enrollments. 
This way they can be found easier in the Student List by applying the PreReg 
filter. 

Grade sub level is a specific set of grades other than the numeric Grades 1 
through 12, KF for Kindergarten and EL for Early Learning. For example, if you 
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had a student who was only half day Kindergarten, you would set their YOG to 
put them in KF, and then set their Grade sub level to KH. 

For SU, GA or AD, enter the YOG for a grade 12 student this year, and then use 
the appropriate sub grade between those three. 

For EU, HS or AN, enter the most appropriate YOG and then the corresponding 
sub grade level between those three. 

f. In Step 4, you can confirm the full name and that you are enrolling the student in 
the correct school, and then click “Finish”. 

g. When the wizard closes, you will be taken to the Demographics/Details page for 
the Student you just enrolled. If you are taken to a different student, it is because 
the newly registered student would not have appeared on the Student List under 
the existing filter. If your filter was set to Primary Active Students, for example, 
and you set the status of your new student as PreReg, the student would not 
appear in the Student List, and you would have to change the filter to find them.  

 

For more about the information on the Student Details page, see Section 6.0 – Student 
Demographics in this document. You may not have to adjust anything for the newly registered 
student’s demographics, if the previous school has kept them up to date. If this is a new 
registration, it will copy some of the demographic information (phone number, address, 
contacts) from their existing sibling. 

  

Tip: set your filter to All Students before registering new students into your 
school, and you will always have them open up to the Details page of your 
newly registered student. 
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2.2 Withdrawing Students from a School 

There will be times when a student will leave your school for reasons other than graduating or 
transitioning from an elementary to a middle or high school. In the event that a student is leaving 
your school mid-year, you will need to withdraw the student from your school. 

 

To withdraw a student from your school, you will be in the School view, on the Student top tab, 
looking at your school’s Student List. Then, follow these steps: 

1. Click the checkbox beside the name of the student you wish to withdraw. 

2. Click the Options menu, and select Registration, followed by Withdraw Student. 

 

3. This will bring up the Withdraw Student pop-up. The student’s name and school will 
already be filled in. You are required to put in a date (it will default to today’s date), as 
well as a Status, generally “Withdrawn”. If a student has existing cross-enrollments at 
another school, this field will auto-populate to Active no primary, and you are unable to 
change this. You have the option of putting in a Code or Reason as it applies to the 
withdrawn student, and there are two checkboxes at the bottom of the pop-up:  

a. Disable related user accounts. This will disable their User Account, and they will 
not be able to access the system. Be aware that a student may have active 
Cross-Enrollments, so you may not want to have this box checked. 

b. Create former school association. This will create a link with your school until the 
end of the school year, so that they will appear in your Student List when the 
“Former Students” filter is applied. This is particularly useful if you still need to fill 
in marks and grades for this student, so you need access to having them in your 
school. See section 5.1.2 – Viewing current and past cross-enrollments for more. 

4.  Click OK. This will withdraw the student. 

  

Note: You only withdraw students who are listed as a Primary student at your school; if you 
are withdrawing someone who is cross-enrolled to your school, but has a primary school 
elsewhere, you will end their school association. See Section 3.2 – Ending Secondary 
School Associations. 
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If your student has future Attendance Records entered into the system after the withdrawal date 
you listed in the Withdraw Student pop-up, you will get the following warning: 

 

To delete the later record, click Yes. Otherwise, click No, and you can edit the date you have 
entered for this withdrawal. 

2.2.1 Withdrawing a Private Student 

Sometimes a student has special circumstances and is marked “private” to hide their 
demographic information from other schools in the district. If you withdraw a student who is 
marked private, the following pop-up appears: 

 

1. Click Cancel to return to the previous screen. 
2. Click Continue to withdraw the student from the school. The following message appears: 

This student is withdrawn and is no longer confidential. 

 

2.2.2 Withdrawn Students and Archiving 

Students that are inactive (withdrawn) for more than four years and that are over six years of age are 
eligible for archive.  The annual archive process moves eligible student records from Production into the 
Archive environment.  The student may be retrieved from the Archive environment and returned to 
Production through an overnight process similar to the PEN request.  There are a few items to consider 
that relate to the Archive process.  

1) Once a Student is archived: 
a) you cannot remove Students from having a shared address until they are retrieved from archive; 
b) shared contact information will be updated if the student is retrieved; 
c) the students’ addresses in District > Addresses may appear to be orphaned (no associated 

person connected to them).  If you delete these records, then when the student is retrieved, they 
won’t have an address; 

d) the students’ contacts in District > Contacts may appear to be orphaned (no associated student 
connected to them).  If you delete these records, then when the student is retrieved, they won’t 
have this contact. 

2) The shared contact icon still displays with non-archived students.  When a user clicks on a shared 
contact icon, however, it will indicate that the contact is unshared (since the student is archived). 

3) Students should be removed from Groups and Snapshots prior to archiving, ideally at the time of 
Withdraw process.  Students that were not removed from groups and snapshots prior to being 
archived can be removed after retrieval. 

Note: This student is currently marked as Confidential. Withdrawing the student 
will remove the Confidential status. Please select ‘Cancel’ if you wish to return to 
the previous screen. 

Note: If a private student is cross-enrolled at two schools and withdraws from either school, he 
or she is still marked private at the other school. 
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4) User accounts remain intact through archive.  Accounts can be managed according to District policy, 
e.g. disabled, by selecting the option through the Withdraw wizard.   

 

These are the expected outcomes for archived student data:  

 Student addresses will be same as they were when archived unless it has been modified through 
shared contacts or through District > Addresses. 

 Exam, FSA and other assessment data will be maintained and kept current. 

 Gradebook data will be lost. 

 Contact data will be same as when archived unless modified through shared contacts or through 
District > Contacts. 

 Documents will be kept current. 

 Fees will remain with the student in their archived state but will not be affected by users in MyEd. 

 Transcript records will remain intact and untouched. 

 IEP data will be kept in an archived state. 

 If a school name or school course name might change for any reason, these will also change for 
the archived student.  

 Student alerts, incidents, attendance, journals, programs will remain intact and untouched. 

 Student enrollment and cross enrollment data will remain intact and untouched. 

 All demographic data for a student will be remain intact and untouched (i.e., all the data you 
would see on a demographic GDE). 

 Sibling relationships are maintained. 
 

 

3.0 Cross-Enrolling Students 

Students are able to take courses from more than one school at a time; they are said to be 
cross-enrolled to additional schools from their main school. 

In MyEducation BC, there are two types of students at a school: Primary students and 
Secondary students. This does not refer to the grade level of those students, but rather what 
school is the main school the student is attending. A student at their home school is considered 
to be a Primary student there. A student at their Cross-Enrolled school is said to be a 
Secondary student there. These terms will show up throughout the application, so be aware of 
their meanings. 
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3.1 Creating Secondary School Associations 

To associate a student with a secondary school: 

1. From the School view, click the Student top tab. 

2. Click Options, and select Create Secondary School Associations. 

The Create Secondary School Associations wizard appears: 

 

3. Select the District year for the cross-enrollment. 

4. Enter the Start date and End date that the student will attend the secondary school. 
These will default to the start and end date of the school calendar. 

5. Enter the Last name, Gender, and Date of birth for the student. These are mandatory. 

6. Click Search. A pop-up lists the student’s name, some demographic information, and 
contact information for the student’s primary school. Click OK. 

The student should now appear in the Student list under the All Active Students filter with a 
Cross-Enrollment icon (     ) in the Alerts column. 

3.1.1 Setting Attendance Management Type for Secondary Students 

Depending on the school preference setting for Secondary School Management, you may need 
to set the Attendance management type for secondary students.  

Option 1 – Setting attendance management type for an individual student 

1. In the School view, click the Student top tab.  

2. Check the box beside the secondary student and click the Membership side tab.  

3. Click the Schools sub-side tab.  The student’s list of former and secondary school 
associations will appear.   

4. Click the blue hyperlink for the record representing your school.   

5. Set the Attendance management type field as appropriate. 

  



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 20 

Option 2 - Setting attendance management type for multiple students 

1. In the School view, click the Global top tab.  

2. Click the Favorite side tab and select the Student School Association table. 

3. Use the filter called Type:  Secondary to filter to the students who are secondary 
students at your school.  Check the Name field to ensure all records are your school.  

4. Review the AttMag Type field and update using mass update or modify list functions.  

3.2 Future Cross Enrollments 

In the event that you are cross-enrolling a student in advance of their attending your school (i.e., 
they WILL be cross-enrolled to your school this current school year, but you are setting it up 
early. A type of PreReg for Cross-enrolled students), you will follow the same steps as above, 
however you will not see your students in the All Active Students filter. You will see the student 
in the All Secondary Students and All Students filters; however they will not have a Cross-
Enrollment icon until their Secondary Association date passes. To see all future-dated cross-
enrollments in your school, select the Future cross-enrollments filter. This will display all 
secondary students in your school whose start date there is after today’s date. 

 

3.3 Ending Secondary School Associations 

Students now can be withdrawn from Secondary schools the same as they are from Primary 
schools, by using the Withdrawal functionality. 

If a student has Active No Primary for their Enrollment Status, this means they have been 
withdrawn from their primary school, and are only taking classes at their Secondary (i.e., Cross-
Enrolled) School. 

If your school is the only active Secondary School for the student, withdrawing the student will 
set the student’s Enrollment Status to Withdrawn. This means that the student will no longer 
appear on any school’s Student List when “All Active Students” or “Primary Active Students” 
filters are chosen. 

To end a student’s Secondary School Association: 

1. From the School view, click the Student top tab. 

Note: Future cross-enrollments only refers to students who will be attending at a future 
date in this current school year. If you wish to see students who will be cross-enrolled at 
some point after the last day in your school schedule, you will need to use the Build view. 
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2. Check the name beside the Secondary student who is now finished with their cross-
enrollment at your school. 

 

3. Click the Options menu, and select Registration, followed by Withdraw Student. 

 

5. This will bring up the Withdraw Student pop-up. The student’s name and school will 
already be filled in. You are required to put in a date (it will default to today’s date), as 
well as a Status of “Withdrawn”. If this is the student’s final existing cross-enrollment, 
you will see a notification across the top indicating there are no more cross-enrollments. 
You have the option of putting in a Code or Reason as it applies to the withdrawn 
student, and there is a Disable related user accounts checkbox at the bottom which will 
disable and lock their MyEducation BC User Account (if one exists).

 

6. Click OK. This will withdraw the student. 

  

Note: If the student has other current cross enrollments at other schools, or has an active 
enrollment at a primary school, you will not be permitted to change the Status field. It will 
remain the same as it was when you began withdrawing this student. 
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4.0 Transferring Students 

4.1 Transferring a Student from One School to Another 

The Transfer Student function allows you to pull a student to your school from another school in 
the province, without taking each individual step of withdrawing them from a school and 
enrolling them at your school during the current school year. The Transfer function is only 
currently available to the District Support (Help Desk/Level 1) and Registrar roles, unless it is 
assigned to another customized or newly created security role. In order to add this function to a 
role, you will need to add Transfer students in the Other column on the Student table in your 
security role. 

 

To perform a Transfer of a student from one school to another: 

From the “Sending School” or District: 

School or District view > Student top tab 

1. Click the blue, hyperlinked name of the student that will be transferred to a new school. 

2. From the Details page for the student, click the Transfer pending checkbox, and then 
click the magnifying glass in the Transfer School > Name field to select the school the 
student will be sent to. 

 

3. Once the Transfer School pop-up appears, find and select the school, followed by the 
OK button. 

4. Click the Save button on the student record to finalize the selection. Your student is now 
ready for the Receiving School to accept the transfer. 
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From the “Receiving School” or District 

School or District view > Student top tab 

5. From the Options menu, select Registration > Transfer Student. 

 

6. When the Student Transfer pop-up appears, click the magnifying glass in the Name field 
to get a list of students who have been assigned to transfer to your school, and select 
the correct student. Fill in the date under the Withdrawal side of the screen. This will 
automatically populate the date field on the Destination side of the screen. You may 
change that date as you require, based on when the student will appear in their new 
school. Code and Reason are not required fields. 

 

7. Locate your student in the Student top tab school list. Click the checkbox beside their 
name. 

8. Click the Membership side tab. You will see a withdrawal (W) record from the student’s 
previous school and an enrollment (E) to the current school.
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4.2 Home School Transfer 

A Home School Transfer occurs when a student needs to swap their Primary and Secondary 
Schools. To perform this task, we will make use of the Transfer function. The Transfer function 
is only currently available to the District Support (Help Desk/Level 1) and Registrar roles, unless 
it is assigned to another customized or newly created security role. In order to add this function 
to a role, you will need to add Transfer students in the Other column on the Student table in 
your security role. 

 

There are three steps to performing a Home School Transfer in MyEducation BC: set the 
transfer of the student from the original primary to the original secondary school (which will 
make the primary); end the cross-enrollment at the original secondary school and complete the 
transfer; and cross-enroll the student back to the original primary school (which makes it now 
the secondary). 

 

  

Note: Before you do a Home School Transfer, you will need to take a screen shot of the 
student’s schedule. You will have to reschedule the student back into their classes at what 
ends up being the new cross-enrolled school (the former Primary School). All information 
(Marks, attendance, etc.) will remain once the student is rescheduled back into the class. 

For our example, we will take a student who is set up as a primary school at Robert Bateman 
Secondary and an Abbotsford Virtual secondary student at Robert Bateman Secondary, and 
perform a Home School Transfer process to switch those schools. 
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4.2.1 Set the Student Transfer flag at the Primary School 

From the “Sending School” or District: 

School or District view > Student top tab 

1. Click the blue, hyperlinked name of the student that will be transferred to a new school. 

2. From the Details page for the student, click the Transfer pending checkbox, and then 
click the magnifying glass in the Transfer School > Name field to select the school the 
student will be sent to. 

 

3. Once the Transfer School pop-up appears, find and select the school the student will be 
transferred to, followed by the OK button. 

4. Click the Save button on the student record to finalize the selection. Your student is now 
ready for the Receiving School to accept the transfer. 

4.2.2 Ending Cross-Enrollment at Secondary School 

The second step to the Home School Transfer is to end the cross-enrollment at the secondary 
school. In our example, our student is cross-enrolled to Abbotsford Virtual school, and will be 
moving there as a Primary student, and finishing up a course or two at Robert Bateman. Before 
beginning, you must go to the student’s Schedule side tab, viewing it in List View to see all 
courses at all schools they are enrolled in. 
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Steps to end cross-enrollment at Abbotsford Virtual: 

1. From the School view, click the Student top tab. 

2. Click the checkbox beside the student’s name, and click the Membership side tab. 

3. Click the Schools sub-side tab. 

4. Click the blue, hyperlinked name of the schools whose association you wish to end. 

 

5. Update the end date to when you wish to remove the student from the secondary school. 

 

6. Save the record. 

Our student will now be “withdrawn” from Abbotsford Virtual. The record will remain in the 
Membership side tab > Schools sub-side tab for historical purposes and the transcript will 
remain intact. She will not appear in the class rosters for any of the sections until we transfer her 
in the next step and reattach her courses. 

  

Note: If you choose today’s date, the student will remain in your secondary school’s student 
list until midnight. As well, the Secondary School alert will remain until that time. If you wish 
the student to be removed immediately, and the alert to disappear, enter a date prior to the 
current date. 
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4.2.3 Transfer Student to New Primary School 

You are now ready to transfer our student from Robert Bateman to Abbotsford Virtual. Transfer 
functionality is a pull transfer, meaning you receive at the new school from the original school. 
This will make the student a primary student in Abbotsford Virtual, and no longer at Robert 
Bateman. 

To Transfer a student: 

1. From the Options menu, select Registration > Transfer Student. 

 

2. When the Student Transfer pop-up appears, click the magnifying glass in the Name field 
to get a list of students who have been assigned to transfer to your school, and select 
the correct student. Fill in the date under the Withdrawal side of the screen. This will 
automatically populate the date field on the Destination side of the screen. You may 
change that date as you require, based on when the student will appear in their new 
school. Code and Reason are not required fields. 

 

3. Click the OK button to finish. Our student is now a primary student at Abbotsford Virtual. 
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4.2.4 Create Cross-Enrollment at “New” Secondary School 

Now that you have transferred your student to Abbotsford Virtual, you need to create the 
secondary school association back to Robert Bateman Secondary. 

To associate our student with Robert Bateman as a secondary school: 

1. From the School view, click the Student top tab. 

2. Click Options, and select Create Secondary School Associations. 

The Create Secondary School Associations wizard appears: 

 

3. Select the District year for the cross-enrollment. 

4. Enter the Start date and End date that the student will attend the secondary school. 
These will default to the start and end date of the school calendar. 

5. Enter the Last name, Gender, and Date of birth for the student. These are mandatory. 

6. Click Search. A pop-up lists the student’s name, some demographic information, and 
contact information for the student’s primary school. Click OK. 

The student should now appear in the Student list under the All Active Students filter with a 
Cross-Enrollment icon (     ) in the Alerts column. 

The last step is to reschedule the student back into the courses at the Secondary School; in this 
case, Robert Bateman Secondary. Go back to your screenshots, and put the student into the 
courses she has remaining to complete at this school. 
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5.0 Other Registration Tasks 

5.1 View a Student’s Enrollment Information 

There are several occasions where you may wish to see a student’s primary and secondary 
enrollments in schools, both current and past. All enrollment information will be located in one 
place: 

Student top tab > select student > Membership side tab. 

5.1.1 Viewing current and past enrollments 

For existing and previous Primary School enrollments (primary meaning “Home” school in 
MyEducation BC), you will look to the Enrollment side tab.  

This will give you a list of all schools that the student has been enrolled in as a primary student, 
along with their current status, as well as what their status is at each particular school. 

For example, The Status column will show that the status of the student at Clayburn Middle and 
William A. Fraser Middle is Withdrawn, however they are Active at both Robert Bateman and 
Abbotsford Virtual. The EnrStatus column shows you what the student’s status is period. i.e., 
PreReg, or Active, etc. 

 

5.1.2 Viewing current and past cross-enrollments 

For existing and past secondary school associations, aka “cross-enrollments”, you will look to 
the Schools sub-side tab. 

This will give you a list of all schools where the student has been cross-enrolled as a secondary 
student. This will also give you a list of all schools where there is a former school association. 
i.e., a former Primary school where they need to still appear in their student lists and to access 
the student for marks, etc. These will go until the end of the school year by default, but can also 
be ended early if necessary. 

Note: If the date of Withdrawal at one school is the same day as the Enrollment at the new 
school, these may appear “out of order”. 
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Each cross-enrollment will be contained within a school year. In the example above, Abbotsford 
Virtual was the student’s cross-enrolled school over two school years, so there are two 
secondary school records for that school, one for each school year, regardless of whether it is a 
full year or not. You can see the Start and End dates for each school association. 

For Robert Bateman Secondary, the student has a Former School Association, meaning they 
were formerly there this year, and will be visible in the Student List under the Former Students 
filter there. They are also cross-enrolled to that school now. 

5.2 Changing a Student’s Registration Status 

When you need to update a student’s registration status – for example, changing a student from 
PreReg status to Active when they are ready to attend at your school – you will do that from 
your Student List, and use the Update Enrollment Status wizard. 

To change a student’s registration status, you will be in the Student List. 

School or District view > Student top tab 

1. Select the checkbox by the name of the student whose status you wish to change. 

 

2. From the Options menu, select Registration > Change Student Status.

 

3. This will bring up the Update Enrollment Status wizard. Here you can put in a date for 
when this change is to take place (usually the current date); fill in the new Status, and 
you have the option of entering in a reason, such as “Updated pre-registration code”. 
You could also choose to disable the student’s User Account at this stage by checking 
the appropriate checkbox. 

Note: If you are attempting to change the status of a student whose current status is not 
Active, you will need to go to that student’s Membership side tab and follow the rest of 
these instructions. 
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4. Click the OK button to make the changes. 

You can see the change made in the following location: 

Student top tab > select student > Membership side tab > Enrollment sub-side tab. 

All changes to Enrollment Status will be indicated with a S. 

 

Clicking the S will take you into the information for the Enrollment Status change: 

 

While the fields may be editable, you should not change the Type or YOG fields here. You can 
adjust the Date or Code if necessary. Entry/Exit Grade is not applicable here, so you can  
ignore it. 

 

Note: While the Grade Level would have been Grade 1 in the above instance, because we 
are looking at it two years later it is reflecting the student’s current grade. Because the YOG 
calculates the Grade Level based on when you are looking at the record, this is why we have 
Entry/Exit Grade on enrollments and withdrawals. 
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5.3 Changing a Student’s Year of Graduation 

There are several reasons why you may need to change a student’s Year of Graduation during 
the school year. You could have an error when the student was enrolled, a student could be 
promoted to the next grade during the year, or any number of reasons based on your school 
business rules. 

You can only change the Year of Graduation (YOG) for an Active student. If they are 
Withdrawn, PreReg or Graduated, you cannot change their YOG. You will either need to wait 
until they are made active or change their registration status following the steps in section 5.2 – 
Changing a Student’s Registration Status above to Active, and then changing them back to their 
proper status once the YOG has been updated.  

 

To change a YOG for a student, you will be in the Student List: 

School or District view > Student top tab 

1. Select the checkbox by the name of the student who’s YOG you wish to change. 

2. From the Options menu, select Registration > Promote/Demote Student. 

 

3. This will bring up the Promote/Demote Wizard. Here you can put in a date for when this 
change is to take place (usually the current date), fill in a reason (if necessary), and the 
new YOG. This will calculate the Grade Level based on the current school year.

 

4. Click the OK button to make the changes. 

You can see the change made in the following location: 

Student top tab > select student > Membership side tab > Enrollment sub-side tab. 

Note: If you change a student’s Year of Graduation in their Student Details page, you will 
see it updated in that screen, but not elsewhere in the application. Always follow the 
procedure below to ensure that the YOG is changed in all places it will be used. 
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All changes to Year of Graduation will be indicated with a Y. 

 

Clicking the Y will take you into the information for the YOG change: 

 

While the fields may be editable, you should not change the Type or YOG fields here. You can 
adjust the Date or Code if necessary. Entry/Exit Grade is not applicable here, so you can ignore 
it. 

6.0 Demographics 

Student Demographics are the quantifiable information about the students – their date of birth, 
contact information, their parent/guardian information, grade level and more. This information is 
begun to be entered when you first register a new student, and continues whenever 
demographic information is updated throughout the student’s attendance in BC Schools. 

6.1 Student Demographics 

When you first register a student, you will collect information like their full legal name, gender, 
date of birth and Year of Graduation (which will calculate their grade level) and can also record 
telephone number(s), address(es), homeroom and home language at the moment you enter 
them into the system. Once they are registered, you can collect a myriad of additional 
information for your students. 

6.1.1 Main Demographics page 

School or District view > Student top tab > select student > Details side tab. 

The Details page is where you can access and enter the Demographic information for your 
students. The bulk of the information for a student is stored here, and along the top are several 
Sub-tabs where more information can be collected and stored. 

In addition to basic student demographic information, the Demographics sub-top tab contains 
fields for populating additional school-level information, such as calendars, homerooms and 
lockers.   



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 34 

 

When you first register a student, you will enter in some of this information so that when you get 
to the Details page, some of this information will already be entered. From here, you can begin 
filling in the additional information you may require. 

6.1.1.1 Formatting of Phone Numbers 

Formatting of Phone Numbers in MyEducation BC follow a very specific format: 

XXX-XXX-XXXX 

If you type in just a string of numbers with no formatting, MyEd will automatically change the 
formatting to match this format when the record is saved. It will not change the formatting if you 
were to put in any other formatting for the phone number, however. 

6.1.1.2 Updating Homeroom Information 

Homeroom assignments can be handled for individual students by using the magnifying glass 
on the Demographics sub-side tab > Homeroom field to select the appropriate homeroom.  
Alternatively, homerooms can be assigned by selecting a group of students and using the Mass 
Update or Modify List functions in MyEducation BC.   

 

6.1.1.3 Parent/Guardian Information 

The bottom of the screen contains information about parents/guardians and other contacts that 
the student will have. You can modify this information here or from the Contacts side tab. For 
more information, see Section 6.2 – Contacts. 

6.1.1.4 Locker Assignment 

Locker setup for your school is covered in the MyEducation BC School Setup documentation. 
Lockers can be assigned to students through the Student top tab: 

 The locker field can be added to a field set in order to use Modify List functionality for populating 
multiple students.  

 Click into the Detail side tab of a student and use the magnifying glass to populate the Locker field 
on the student’s Demographics sub-top tab. 

6.1.2 Addresses 

From the Addresses sub-top tab, you can enter both the Physical address and Mailing address 
for a student. If the Mailing address is the same as the Physical one, you may check the is 
identical checkbox beside the Mailing Address field and it will tell the system that it is the same 
information. MyEducation BC will copy that value into the Mailing Address field, so it will be 
displayed in the field sets where the Mailing Address field is included and on the Addresses 
sub-top tab in the Student Details page and be searchable using a Query. 

There is also a pull down menu for Proof of address, if your district requires this, with a list of 
different proof types. 
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6.1.2.1 Formatting of Addresses 

Addresses in MyEducation BC are actually concatenated smaller fields that must fit a specific 
format. When saving the address, a validation procedure will be run, and may stop you from 
saving the information if the address does not match this format. Data that has been converted 
or imported in may not cause a validation error until you attempt to change the address data on 
the student record. At that point, you will need to put the information into the correct format. 

Canada Post conventions for street types have been applied to the validation of addresses, so 
abbreviations must be used when entering a street type.  The validation tool provides a 
selection list for valid street types, if required. 

 

Address Component User enters . . . 

Apt/Unit/Complex Only the number or letter of the apartment, unit or complex. Do not preface 
the letter or number with Apt, Unit, etc. 

Street number The street number of the building 

Street prefix Street prefix, if there is one. 

Street name Name of the street, without the street type 

Street type Street type as per Canada Post abbreviation conventions.  Example:  Rd, St, 
etc. 

Street post direction Street direction that comes after the street name, if there is one.  This value 
should be the abbreviated street direction.  Example:  Gordon St SE 

Street pre direction Street direction that comes before the street name, if there is one.  This value 
should be the abbreviated street direction.   Example:  N Gordon St 
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The second set of fields will be for RR Number or PO Box.

 

Address component User enters . . . 

RR Number/PO Box This field may contain:  RR, PO BOX, LOT, CONC or GD information.  When 
entering data, these fields should be entered in block caps as follows: 

 RR  

 PO BOX 

 LOT 

 CONC 

 GD 

The last set of fields in the address will be City, Province and Postal Code. 

 

Address Component User enters . . . 

City Name of the city, town, etc. 

Province 2-Digit Provincial code, i.e., BC or YK 

Postal code Postal code in Canada Post convention format  A1A 1A1 
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6.1.2.2 Entering Addresses in MyEducation BC 

1. Type in your address into the fields given. 

2. Click on the  icon at the end of the address field to open up the validation window. 

3. In the pop-up validation window, verify that the address components appear in the 
correct fields, by clicking the Validate button. 

4. If a validation warning is received on entering this window, verify the address 
components appear in the correct fields.  

a. If they appear that they are correct, check the User validated checkbox. This will 
open the address fields to be populated manually. 

 

b. Type the address components into the appropriate fields. 

c. Click OK, then the Save button. 

6.1.2.3 Shared Addresses 

If an address is already in MyEducation BC, attached to a sibling or contact, you can use the 
magnifying glass to select the address from a list. Autofill suggestions may appear once you 
have typed enough of the address to trigger a match in the system. When selected, this will 
automatically populate the entire address and identify it as a shared address between the 
student and the sibling or contact you selected. Subsequent changes to this shared address will 
prompt the user to choose if they want to update the address for any or all records attached to 
the shared address. 

The “Shared Address” icon will then appear. 
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6.1.3 Alerts 

On the Alerts sub-top tab, you will be able to see three Alert categories. Student alerts are 
important bits of information about a student that are represented by an icon next to the 
student's name on student pages. These icons alert users to information they should know 
about a student. The information you enter about each alert will be visible to any user who has 
Read access to the Alerts table in their Security Role. 

6.1.3.1 Legal Alerts 

Legal alerts  can inform users about certain legal situations they should be aware of. 
These are most often used for child custody, safety or legal issues surrounding the student’s 
family situation. Some court documentation is typically on file at the school for these students. 
Adding a Legal Alert will create a checked Legal Alert box on the student PSR and an inclusion 
note that there is a legal document on file that impacts the student. 

6.1.3.2 Medical Alerts 

Medical alerts can inform users about a student’s life-threatening medical condition. Other 
health conditions that are not considered life-threatening will be stored in the Other Alerts 
category using Health Alert. These two different types of alert will produce different alert icons. 
Adding a Medical Alert to the student will create a checked Medical Alert box on the student 
PSR and an inclusion note that a medical condition exists – please see student file.  

6.1.3.3 Other Alerts 

Other alerts can inform users about any other important information staff members should 
know about a student, such Family Alerts, Health Alerts or other Information Alerts. When you 
create an Other alert, you select the icon you want to appear.  

The most common example of an Other alert would be the Health alert. This will be used for 
non-life threatening medical conditions.  

To create a Health alert, you will click the Add button underneath the Other Alert field, to 
bring up the Other Alert pop-up. Fill in the description for that Health Alert and choose the 
“Health Alert” icon from the pull down menu. Click the OK button to finish the pop-up, and then 
the Save button on the Alerts page. 
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The Family Alert icon is most often used to note information on a student’s family situation that 
is not related to safety or legal matters for that student. 

The Information Alert would be used for any other informational alert that you would want users 
to know about that student. 

6.1.4 Citizenship 

The Citizenship sub-top tab contains information about a student’s Country of Birth, Country of 
Citizenship and corresponding Citizenship code. This page will also contain information for 
International students, such as Length of Stay, Visa Status and Expiration Date. 

6.1.5 Programs 

The Membership side tab Programs sub-side tab is where you will assign any General Student 
Programs that a student may be a member of. If a student is assigned a program, it will be done 
here, and other users may view what programs a student is assigned to. 

To assign a program to a student, set the data dictionary  to General Programs, Options> 
Add to bring up the Student Program pop-up. When this appears, you can choose the Program 
code using a pick list. Then assign your school, the start date and end date (if necessary). If this 
is an aboriginal program assignment, users may choose to add additional information using the 
Ab school liaison and Ab comment fields.  

 

To modify existing program assignments, you can click the blue, hyperlinked name of the 
program and update the information in the fields as required. 

The second part of the Programs page is the Years of ESL section. This information is loaded 
by the Ministry of Education, and while this value can be modified here, it is recommended to at 
least speak with the Ministry before changing this field. 

6.1.6 Student Services 1701 Designation Programs 

The 1701 Designation is managed through the School View > Student top tab > Membership 
side tab > Programs and is restricted by an add-on security role.   

To assign a 1701 Designation Program: 

 School or District View > Student top tab > Select the Student > Membership side tab > 
Programs.    

 Set the Dictionary Menu to Student Designations and the Field Set to Default Fields 
(Student Designations) 

Note: To add additional Program Codes to the pick list, you can go the Reference Table at 
the District level and locate the Student Programs table. Here, you can add codes that will 
become available to all schools in your district. 
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 Options > Add  

o Select the Student Designations template in the upper right corner 

      

o Select the appropriate Designation from the pick list 

o If this is the Primary Designation, check the Primary designation check box 

o Enter the Start Date 

o End Date may be entered or may be left blank per district standards 

o Save 

Considerations 

 Students may have multiple designation programs assigned, if they are applicable, but 
only the primary designation will populate the 1701 Designation field.   

 The Primary Designation is identified by the Primary Designation check box in the 
Program Screen.  Only one Designation may be the Primary Designation.   

 When a new Primary Designation is created the previous primary designation will 
automatically end date.  The end date may be removed if applicable.    

 

6.1.7 Permissions 

The Permission sub-top tab allows you to indicate which permissions that parents or guardians 
have given for certain student’s information. The fields that appear on this tab include Send 
Email & Autodialer Calls, Release of Info/Photos Outside of District, Permission to Walk Home, 
Allow Internet Access, and Field Trip Permission. 

These fields are strictly informational and do not have functionality outside of this page; if you 
set Send Email to “No”, it will not remove the parent from the email list when you bulk-send 
emails to all parents/contacts from the system. 
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6.1.8 Language & Culture 

The Language & Culture top tab is a place where you can record what languages are spoken 
in the home, which are most used and their first language. On the other side of the screen will 
be where you record their Aboriginal Ancestry, Band of Residence and Status Card Number. 

6.2 Student Contacts 

MyEducation BC stores information about a student’s contacts and related students. This data 
can be shared among other students, as can their addresses and other contact information. 

6.2.1 Parents/Guardians/Other Contacts 

Information on Parents/Guardians and other emergency contacts can be found in two locations 
in MyEducation BC: 

School or District view > Student top tab > Details side tab 

 The Contact information is at the bottom of the Student details page. 

School or District view > Student top tab > Contacts side tab 

 This contains the same contact information as found on the Details page. 

Both of these locations have the same information. The Contacts side tab allows you to change 
the field set to whatever fields you may require for these contacts. The Details page allows you 
to access the majority of the student’s information on a single page. Either one will allow you 
add or remove contacts easily if necessary. 

Contacts default to being sorted by Emergency Priority. The highest priority should be 1; 
Doctors and Dentists will be converted in as having a priority of 99. You can modify any contact 
to change the priority or any other field by clicking the blue, hyperlinked number for their 
Emergency Priority, and then saving the record. 
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6.2.1.1 Adding a New Contact in MyEducation BC 

If you are adding a contact that has never existed in MyEducation BC,  

go to the Contacts side tab, click Add from the Options menu: 

 

Once on the New Contact page, you can enter the demographic information for that contact. 
Fields include first and last name, gender, phone numbers, email addresses, place of 
employment and addresses. You can also record their relationship to the student, whether they 
are a Parent/Guardian, What their Emergency Priority is (1 is the highest value), and several 
check boxes along the right side to indicate whether the Contact lives with student, Contact can 
pick up, if they will receive grade mailing, receive conduct mailing, receive other mailing, receive 
email; if the contact has family portal access, and if they should be included on IEP. 

 

Some of the information you enter here will be informational only – it does not have function in 
MyEducation BC. Contact has family portal access and Include on IEP do actually have function 
within the application: The former allows the Contact to see that student’s information in the 
“Family view” if they have an account created, and the latter allows them to see IEP information 
on that student. 

Addresses will be input on the Addresses sub-top tab. If this will be the same address as the 
student, you will want to connect this address with the student’s address. Autofill suggestions 
may appear once you have typed enough of the address to trigger a match in the system. If you 
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click the autofill suggestion, it will fill in the rest of the fields and when you save the contact, it 
will create a “Shared Address” icon: 

 

 

If you do not get an Autofill suggestion, you can click the magnifying glass at the end of the 
Street address field. This will bring up a pop-up with a list of addresses that match what you 
have typed, and an “owner” field indicating who lives there. If none appear, you may have typed 
the address differently than exists in the system. Selecting one and clicking OK will autofill all 
fields and give you the “Shared Address” icon. 

If your contact does not have a shared address with another person in the system, simply fill out 
the remaining fields and click the Save button. There will be a “Not-Shared Address” icon 
displayed at the end of the Street address field: 

 

6.2.1.2 Adding a Contact That Already Exists in MyEducation BC 

If the contact already exists in the system for a different student, you may attach that same 
contact to another student. Click the magnifying glass at the end of the surname when inputting 
a new contact and it will attempt to match the surname or next closest surname.  

You will want to change the Selection type to “All Contacts” if this person is a contact already in 
the system. If the contact is an existing staff member, you can choose “All People” from the 
Selection type list, and this will give you a list of all contacts, staff and students already in the 
system. If there are multiple people with the same first and last name, you can match the person 
with the physical address for that person.  
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Once you have assigned the shared contact, you will see the Shared Contact icon at the end of 
the surname. This lets you know that the contact has been shared correctly between the two 
students. 

 

When you share a contact, this will auto-populate all the existing fields that have already been 
filled out for this person, including gender, phone numbers, email addresses, and physical & 
mailing addresses. Clicking the Address sub-top tab, this will display whether the contact has a 
shared address. This may not mean that the contact has the same address as your student; 
they could have a shared address with the other student or another contact that they are 
attached to. 

 

6.2.1.3 Deleting Contacts 

If your contact is no longer applicable to your student, you may delete them. Once deleted, they 
will still be available when assigning a contact to another student down the road, by selecting 
them from the pick list as shown in Section 6.2.1.2 – Adding a Contact That Already Exists in 
MyEducation BC. 

To delete a contact, you can check the box beside their name in the Contacts section at the 
bottom of the Details page, and click the Delete button, or else from the Contacts side tab, and 
then select Delete from the Options menu. 

6.2.2 Siblings/Related Students 

When you have enrolled a student as a sibling (see Section 2.1.3 – Admitting related students), 
they will appear in the Contacts side tab > Related Students sub-side tab. If you wish to add a 
sibling/related student to another, when both are already enrolled, you may also do this from 
this location. 
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6.2.2.1 Creating a related student record for two students in the system. 

From the Student top tab, select your student by clicking the checkbox beside their name. 
Then, from the Contacts side tab > Related Students sub-side tab, select Add from the 
Options menu. 

 

This will produce a page that has a Name field with a magnifying glass to select your student, 
along with a Relationship pull down menu to select how the related student is connected to your 
student. 

 

Click the magnifying glass to select your related student. This will produce a pick list of all active 
students in your District. Select that student and click the OK button. Choose the relationship 
between the two students and click the Save button. 

In order to display the information on the Student Details page, you will need to make sure that 
each student connects to each other: Student A must connect to Student B, and then Student B 
will connect to Student A. 

 

  

Note: If you need to connect two students who are not in the same district, this can be done 
by the Fujitsu Service Desk at the Enterprise level. 
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6.2.2.2 Deleting a related student 

To delete a relationship between two students, click the checkbox beside your student’s name, 

and choose Delete from the Options menu. 

 

6.3 Program of Study 

Student graduation programs are known as Programs of Study and do not automatically 
populate in MyEducation BC.  It is recommended that this field be populated as part of the 
registration process.   

6.3.1 To add a program of study to an individual student: 

1. In the School view, click on the Student top tab. 

2. Find the student that requires a program of study and check the box beside their name. 

3. Click the Transcript side tab.  

4. Click the Programs of Study sub-side tab.  

5. In the Options menu, select Add.  A new window appears to enter the graduation 

program information.  

6. Click the  to open the Graduation Program Pick List window.   

7. Click the radio button to select the appropriate graduation program in the list.   

8. Click OK to close the pop-up window.  The selected program will now appear in the 

Name field.  The Total credit, Diploma type, and Description fields will auto-populate. 

9. Check the box for Primary program study. 

10. Click Save. 



 

MyEducation BC Enrollment and Demographics v2.1 

 Page 47 

 

6.3.2 To add a program of study to multiple students: 
1. In the School view, click the Global top tab.  

2. Click the Favorite side tab.  

3. Click the blue hyperlink on the Graduation Student Program table.  

4. Update student graduation program values using modify list or mass update functions. 

6.4 Updating Diploma Granted Dates 

Diploma met dates may be updated prior to End of Year Rollover (EOYR) to confirm students 
who are graduating.  It may also be necessary to update Diploma met dates for students who 
did not meet graduation requirements before EOYR, but have completed summer school 
courses to complete their programs.   

6.4.1 To enter Diploma Granted Date for an individual student: 

1. In the School view, click the Student top tab.  

2. Click the Details sub-side tab and select the Demographics sub-top tab.  

3. Use the date selector icon or type in the Diploma Granted Date that reflects the effective 

date on which the student fulfilled graduation requirements. 

6.4.2 To enter Diploma Granted Date for multiple students: 

1. In the School view, click the Global top tab.  

2. Click the Student side tab.  

3. Click the blue hyperlink on the Student table.  

4. Select the field set called Diploma Granted.     

5. Update Diploma granted date values using Modify List or Mass Update functions. 

 

Note: If using Mass Update, ensure that the only students in your list are ones you 
intend to update.  There is no way to mass update date fields back to a blank value. 
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6.5 Inclusions 

Inclusions will appear on the Permanent Student Record (PSR) report.   To enter an inclusion 
for a student: 

1. In the School view, click on the Student top tab. 

2. Find the student requiring an inclusion record and check the box beside their name. 

3. Click the Transactions side tab. 

4. Click the Inclusions sub-side tab.  

5. In the Options menu, select Add. 

6. The New Inclusion page opens: 

 

a. In the Inclusion date field, type or use the calendar icon to select the effective 
date of the inclusion. 

b. In the Inclusion type field, indicate the type of inclusion being recorded, the type 
must be prefaced by the word: Inclusion and then the number sequence (01, 
02, 03). The word Inclusion and the sequence number will determine if and in 
what order the inclusion prints on the PSR. 

c. In the School year field, use the icon to select the year the inclusion is 
recorded for. 

d. Use the PSR Comment field to record the necessary information. 

7. Click Save. 

  

Note: Guidelines on Student Record Inclusions for the Student Permanent Record can be 
found on the Ministry of Education website at as per the Ministry of Education instructions at 
http://www.bced.gov.bc.ca/classroom_assessment/psr_instruct.htm 

http://www.bced.gov.bc.ca/classroom_assessment/psr_instruct.htm
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7.0 APPENDIX 1: Enrollment Reports 

7.1 Enrollment Activity 

School view > School top tab > Reports menu > Enrollment Activity report 
School or District view > Student top tab > Reports menu > Enrollment Activity report 
District view > District top tab > Reports menu > Enrollment Activity report 

The Enrollment Activity report will give a list of all enrollment tasks done at a school within a 
district; the report shows Enrollments, Withdrawals, Status changes and YOG changes between 
two user-identified dates within a school year. The user can choose to sort the results by Date, 
Name, YOG, School (if done by District) and Type (i.e., display all Enrollments first, then all 
Status Changes, etc.). 

The final report displays all of the sort fields, as well as any Code and/or Reason that may be 
entered when the enrollments were done. 
 

Enrollment Activity input screen

 
 
 
 

  

Enrollment Types: 
E=Enrolled 
W=Withdrawn 
S=Status Change (i.e., PreReg to Active) 
Y=Year Of Graduation change (i.e. holding a student back a year or skipping a grade) 
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7.2 Enrollment Breakdown 

School view > School top tab > Reports menu > Enrollment Breakdown report 
District view > District top tab > Reports menu > Enrollment Breakdown report 
District view > District top tab > Schools side tab > Reports menu > Enrollment Breakdown 
report 

The Enrollment Breakdown report will produce a report that allows you to see the breakdown 
across the Grade Level or Age of your school or district. The report will run from the beginning 
of the school year until a date you specify, and then you may choose a field on the Student 
table to calculate your totals. 

For example, you can run this report to see how many enrollments you have had by grade and 
by Aboriginal Ancestry at your school. This will display the number of Inuit, Metis, Non-Status 
and Status-Off Reserve you have per each grade in your school, with totals at the end. 

 

Enrollment Breakdown input screen:

 
 
 

7.3 District Enrollment 

District view > District top tab > Reports menu > District Enrollment report 

The District Enrollment report will give you a breakdown of the enrollment statistics for each 
school by grade level. Each school will list how many students are active in each grade, along 
with a total for each school. The columns will also give a total for how many students are active 
in each grade for the entire district. 
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8.0 APPENDIX 2: Demographic Reports 

8.1 Student Profile 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Profile 

The Student Profile report prints out individual sheets for each student you select. You can 
choose to run it for the Selection on your screen, or else you can choose to run it for All 
students, or by YOG or Homeroom. The Input screen allows you to only run for Active students, 
and whether or not to include Secondary students. 

Student Profile input screen:
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8.2 Student Directory 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Directory 

The Student Directory report prints out a list of each student you select, one student per line. 
You can choose to run it for the Selection on your screen, or else you can choose to run it for All 
students, or by YOG or Homeroom. The Input screen allows you to only run for Active students, 
and whether or not to include Secondary students. 

 

Student Directory input screen:
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8.3 Student Contacts 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Contacts 

The Student Contacts report prints out a page for each student in a school that you identify that 
displays the student’s Name, Pupil # and Homeroom, along with all contacts associated with that 
student. The contacts will list the Emergency Priority number, Name, Relationship and two phone 
numbers for each contact. 

Student Contacts input screen: 
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8.4 Student Address Labels 

School or District view > Student top tab > Reports menu > Student Address Labels – 5161 
School or District view > Student top tab > Reports menu > Student Address Labels – 5960 

There are two sizes of Student Address Labels available in MyEducation BC: Ones that are 
formatted 1” x 4” for Avery 5161 (also will fit 5961) and 1” x 2.63” for Avery 5960 (will also fit 
5160) labels. 

Student Address Labels – 5960 input screen:
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8.5 Permanent Student Record 

School or District view > Student top tab > Reports menu > Permanent Student Record 

The Permanent Student Record report is used to document the history of a student’s 
education program. The report will track a student’s enrollment information, inclusions, 
attendance and achievements. 

You are able to print the report for a Selection of students on the screen (highlight students by 
checking the boxes beside their names, and choosing Show Selected from the Options menu), 
All students in your school, a specific Year of Graduation (YOG) or a Snapshot of students that 
you have saved. 

Permanent Student Record input screen:

 

 
 

8.6 BC Student Information Verification Form 

School or District view > Student top tab > Reports menu > BC Student Information Verification Form 

The BC Student Information Verification Form is a full report of the student’s demographic 
and contact information that is sent home with the student for a Parent/Guardian to enter or 
confirm existing information on the student. You have the option of printing the form with the 
student’s information, or you can print a blank form for the Parent/Guardian to fill in. 
  

BC Student Information Verification Form input screen: 
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8.7 Other Demographic Reports 

8.7.1 Birthday List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Birthday List 

The Birthday List report will print out a list of birthdays for the students at a school that match your 

input type: Current Selection, All, a Single Day, a Week or a Month. You can sort the results by 
Date or Name. 

8.7.2 Bus List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Bus List 

The Bus List report will give you a list of what bus routes students are expected to take arriving to 
school, leaving school or both. 

8.7.3 Homeroom List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Homeroom List 

The Homeroom List is a summary of the rosters of each homeroom in your school. The report 
prints out the Homeroom number and Teacher name, along with the Pupil #, Name, YOG and Sex of 
each student. 

8.7.4 Locker Assignments 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Locker Assignments 

Locker Assignments will give you a breakdown of what lockers are assigned to which students. 
You may choose to run the report for All students, Students without lockers, All lockers, Unassigned 
lockers or All lockers and students. The report will display a student’s Pupil #, Name, YOG along 
with the Locker # and Combination for which it is assigned. 

Refer to the School Setup reference guide for information about assigning lockers to students. 

8.7.5 Student Alerts 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Alerts 

The Student Alerts report will allow you to print out a summary of Student Alerts for a selection of 
students that you determine based on All students, a particular YOG or an individual Homeroom. 
You may also decide to print the report for only Medical Alerts, Legal Alerts, Other Alerts or All.  

The report will give a list of all Alerts for all students that were chosen in the Input screen, along with 
the descriptions for each Alert. 

8.7.6 Student List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student List 

The Student List is a list of chosen students in your school, based on a Selection, YOG, Homeroom 
or All students. When run, you can choose how to sort the list, by Name, YOG or Homeroom. This 
report will display the Pupil #, Name, YOG, Sex and Homeroom for each student listed. 


