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1.0 Scenarios 

A build scenario defines the structure of the schedule that a school would like to build for next 
year, including the schedule terms, number of periods, and number of days per cycle. 

Several build scenarios can be created to test out different structures. For example, a school 
might use a scenario to build their traditional master schedule. Even if they are happy with the 
schedule, they may want to tweak it to see if they can get a better schedule. To be safe, schools 
should copy the scenario and schedule and just tweak the copy. Then, they would only commit 
the schedule they will actually use next year. Depending on the scenario preferences selected, 
attributes of each can be shared or they can be distinctly unique. 

1.1 Creating Scenarios 

There are two ways to create the schools initial scenario: by Adding new or Copying the existing 
active schedule. 

1.1.1 Add new 

1. Build view. 

2. Click the Scenario tab. 

3. On the Options menu, click Add. The New Schedule page appears. 

4. Enter a name for the scenario. If more than one scenario is being created, use short 
descriptive names, e.g. 1-12Feb. 

5. The system enters the start and end dates that coincide with the build context year. 
There is no need to change these dates. 

6. Comments area:  This is a text box which can be used to describe this scenario. 
Comments are very helpful if you will be creating multiple scenarios. 

7. Click Save. 
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1.1.2 Copy Active Schedule 

Build view > Scenario > Options > Copy Active Schedule… 

A new parameter window opens providing options on specific parts you would like to copy. 

NOTE: It is important to understand both what the school did last year and how they would like 
to schedule this year, when choosing these check boxes. 

 

 

 



 

Module 3 Scenarios, Preferences and Time Structures v1.7 Page 6 

 

 

Field Description 

New scenario name Enter a name for the scenario. If you plan to create more than one scenario, use 
short descriptive names. E.g. 1-12Feb 

Master schedule Check if you want to copy the current year Master Schedule 

Clear platoon codes Check if you do not want to copy platoon codes from students and sections 

Student schedules Check if you want to copy students existing schedule 

Rules Check if you want to copy Load rules.   Build rules do not exist in the 
School view.  All Rules can be copied into the scenario later. 

Rotation* Check if you want to copy the existing rotation.  If this is selected, the 
schedule CANNOT be rotated again. 

NOTE: Field is only present if a Rotation existed for last year. 

Unrotate schedule* Check if you want to copy the schedule with the original structure, prior to a 
rotation being applied last year. 

NOTE: Field is only present if the schedule was rotated last year and 
applied. 

Bell schedule Check if you want to copy existing Bell schedules     All Bell schedules can 
be copied into the scenario later. 

 

1.2 Scenario Preferences – Scenario Basic 

Define build scenario preferences that you want the system to consider when building the 
schedule with this scenario. 

Note: During the School year, you can view the build scenario preferences for the current 
master schedule in the School view. Click the Schedule tab, and the Preferences side-tab. 

To define build scenario preferences: 

Build view > Scenario > Select the scenario > Preferences > Category defaults to Scenario – 
basic 
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1.2.1 Schedule Expression Format 

The default for the schedule expression is Period first. The period is displayed in the schedule 
expression first, followed by the day i.e. P(D).  

 

 

Note:  It is recommended that districts decide on a standard expression format for all schools to 
follow. The only indication of this setting in the School View is found from Schedule > 
Preferences which will display the preferences as shown above, for the current school year. 
Viewing schedule expressions as displayed within the application will not indicate the set 
preference. 

1.2.2 Use Numeric Section Numbers 

Check this box to have the system generate numeric section numbers. Section numbers can be 
manually changed.  If this box is checked it will ensure when a section is added, it will be 
sequential in numbering. 

1.2.3 Use Study Halls 

This functionality is not currently used in BC. 

1.2.4 Use Rotation 

Select this checkbox if you will be using a schedule rotation. 

1.2.5 Use Bell Schedule 

Only check if the school operates with multiple time structures.  For example  

 Grade 9 students attend 5 periods in a day and; 

 Grades 10-12 students attend 4 periods per day. 

Note: If this is the case schools will need to ensure they use a Bell – Course Restrictions rule 
see Module 7 Rules for additional information on this. 

1.2.6 Control Inclusion Students 

Controls the number of inclusion requests, per section. 

This can be set by Ratio % of the class enrollment total, or by Count with an overall limit set by 
number. 
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This preference setting controls the number of student requests (flagged as inclusion requests) 
that can be loaded into sections. 

Example: 

A school has three sections of MEN—09, all of which are set as inclusion sections. 

There are 90 student requests for this course.  

Of these, nine requests have been flagged as ‘Is inclusion section?’.  

If the preference is set to By count = 3, then the Load engine will schedule three of these 
requests, into each section.  

Note:  There is no link between a student having a Ministry Designation and the student’s 
request being flagged as an inclusion request. 

The image below shows how a student’s request can be flagged as an inclusion request. 

 

 

1.2.7 Include Optional Requests 

Student course requests can be set as ‘Is optional?’. Where this is the case, checking this 
scenario preference will treat these requests as primary. This is rarely used and will be covered 
more thoroughly in Module 4: Student Course Requests. 

1.2.8 Use Reserve Seats 

Checking this preference allows for setting aside seats in a section of a course on the 
Workspace that can be filled after the schedule has been built. This feature could be useful in 
managing the number of students loaded into a section, to ensure space is retained for students 
arriving in Sept. or returning in the following spring. 

Examples: 

1. Hockey players who you know are coming to your school in Sept., but you don’t know 
who they are and therefore don’t have specific requests for them.  

2. International students, you know x number are arriving, but during the scheduling 
process you do not have requests for them.  



 

Module 3 Scenarios, Preferences and Time Structures v1.7 Page 9 

3. Hockey players returning, after their season is complete, and therefore require a seat in 
a section. 

1.2.9 Use Content Term Code 

This preference is checked where schools will be offering students the means of completing 
term portions of a course where they did not meet requirements in an earlier attempt. For 
example as student did not pass semester one of a full year course, they could request to 
repeat only semester one of the course. Where this preference is not checked, the student 
request will be treated as that for the entire duration of the course. 

1.2.10 Show: Location, House, Team, Platoon, Section Type 

Checking these preferences controls whether these fields are displayed for use with student 
groupings in the Workspace, course section details and student details in the build view. Should 
the user expect to see any of these fields and does not, they only need to check the appropriate 
preference and save. 

1.2.11 Use Student Schedule Weight 

Select this checkbox if this scenario uses student schedule weights. 

By default students are scheduled with a weight of 1, which is interpreted by the builder as 
occupying one seat. If selected, this option displays a Schedule weight option on the student 
details in the Build View enabling the user to define this field. For example, a special needs 
student requires equipment and an aide. By assigning a schedule weight of 2; the course 
enrollment is now two seats closer to the maximum enrollment. 

 

1.3 Scenario Preferences – Scenario Advanced 

1.3.1 Engine Processing Time 

Recommendation: Do not change any of these preference settings: Teacher look ahead, Room 
look ahead, or Schedule student. 

1.3.2 Max Count for Same Validation  

This preference setting limits the maximum number of times the system will display the same 
validation error when you validate your workspace. The default value for this field is set to 20. 

1.3.3 Use Shared Attributes 

Users can choose to share various scenario attributes which include: course attributes, staff 
attributes, student attributes, and time structure. Selecting any of these checkboxes uses the 
same attributes shared by other scenarios of the same build year. Changes to shared attributes 
are applied to all scenarios which have the given attribute checked. 
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1.3.4 Relax Room Constraint 

Recommendation: Schools should not use this preference, rooms can be managed best using 
other means. 

1.4 Scenario Preferences – School 

The 5.6 release of MyEd made a couple of changes to this screen, an Advanced tab was added 
and ‘Shared build year scenario’ functionality allows for sharing secondary student schedules, 
with the student’s other school’s  

 

 

 

1.4.1 Schedule Mode 

Schedule mode must be set to Secondary for all schools. 

1.4.2 Elementary Schedule Grade Level Cut-off 

This setting has no effect with the schedule mode set to secondary. 
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1.4.3 Section Number Pad Length 

Section number pad length refers to the system default length of the section number. This can 
be manually changed for any given section. The default setting is 3. 

Recommendation:  Do not set the length to 1. This can result in schedule issues should more 
than nine sections be required for a given course or courses. 

See Appendix A for a detailed table of scenario preference definitions. 

 

1.4.4 Pattern Day and Period IDs (Advanced tab) 

By default pattern day IDs are set as alpha and period IDs are set as numeric. These settings 
determine how patterns are displayed and how the schedule expression is displayed. For 
example, with a schedule expression format of period first the examples below shown from left 
to right would look like: 1(A), 1(1) and A(1) respectively to show period 1/day 1. 

 

1.4.5 Shared build year scenario 

This allows a school to ‘share out’ their scenario, so student’s secondary school(s) can see the 
student’s schedule. 

1.5 Copy a Scenario 

Users can create a new scenario copied from an existing scenario. If you copy a scenario from 
a different schedule build year, the system does not copy the term dates from that year.  

To copy a build scenario: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Select the scenario you want to copy, and click the Details side-tab. 

4. On the Options menu, click Copy Scenario. The Copy Scenario dialog box appears: 
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5. Type a name for the new scenario. 

6. Select the checkbox of the items you want to copy from the original scenario to the new 
scenario. For example, you might want to carry over the rules created but not the 
student schedules. 

1.5.1 Copy Active Schedule 

MyEducation BC provides the ability to copy the currently active schedule in the school to create 
a new scenario in the Build View. This scenario can then be used to create next year’s 
schedule.  

To copy the active schedule: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. On the Options menu, click Copy Active Schedule. The Copy Scenario dialog box 
appears: 

 

 

4. Select the pieces of the active schedule you want to copy into this new scenario, such as 
the master schedule, rules, and rotations. Select the Clear platoon code check- box if 
you want to clear the platoon codes associated with the active schedule. 
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Note: Only checkboxes for items that apply to your scenario appear. For example, if the 
active schedule does not use a bell schedule, you will not see a Bell schedule checkbox. 

5. Click OK. 
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1.6 Terms 

Schedule terms are the date ranges during which a course can begin and end.  

For the functionality of Update Designation/ELL Tallies, to accurate determine student program 
participation (ELL) Term start and end dates need to be added. 

From the Build View, go to the Scenario top tab and click on the desired scenario. Go to the 
Terms side tab. Terms carried over from the current year will be displayed. It is important to 
click into the details of each schedule term. All schedule terms must have a schedule term code 
in the Schedule Term reference table. Some current year codes have been converted without 
existing in the reference table. These can be identified by an asterisk (*) beside the code. 

 

 

 

1.6.1 Adding Schedule Terms to the Reference Table 

To add schedule terms to the reference table, go to the Build View > Global > Reference > 
Schedule Term Codes > Codes > Options > Add. Enter a code that will be meaningful to the 
users and Save. 
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1.6.2 Adding and Defining Schedule Terms  

1. To add additional schedule terms go to Scenario > Terms > Options > Add. 

2. From the Code drop down list select the desired schedule term. If the term code 
representing the required schedule term does not appear, add the code into the 
reference table as described above. 

 

3. Use the following table to enter information in the fields: 

Field Description 

Code Select the code for the schedule term. For example, you might select FY 

for a full-year term, and S1 for Semester 1. 

Note: School users with the security role of Schedule Builder can create these 
schedule term codes from the Build View > Global > Reference > Schedule Term 
Codes > Codes > Options > Add 

Name Type a name for the schedule term. 

Base terms 
per year 

Type the total number of this type of schedule term in your schedule. For example, for 
a course that meets one-third of the year (a single trimester), there are three base 
terms. For a course that meets half of the year (a single semester), there are two 
base terms. 

Term map Select the checkbox that represents which of the base terms this specific schedule 
term covers. For example, if you are defining Semester 1 and there are two base 
terms, select the first checkbox to indicate that this term is the first of the two terms. 

Note: The system displays checkboxes that equal the number of base terms you 
identify at the Base terms per year field. For example, if you identify 3 base terms, 
three checkboxes appear. 
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Field Description 

Term date 
ranges 

Type or click to select the start and end dates of this schedule term. The system 
validates these dates against the school year dates. For example, you cannot enter 
a start date that is before the first day of the school year.  

For the functionality of Update Designation/ELL Tallies, to accurate determine student 
program participation (ELL) Term start and end dates need to be added. 

Grade term 
cover map 

Entered in the School view, after schedule has been Committed. 

 

4. If schedule terms exist that are not required, these can be deleted by clicking into the 
details of the schedule term and going to Options > Delete. 

1.7 Days 

Your schedule might consist of several days per schedule cycle. This way, students can attend 
different classes on different days in a schedule. Many schools follow a flat, two day schedule 
where full year courses are offered on a day 1 or day 2 while the semester courses are offered 
on both. Schools that offer back to back or double blocks of courses where attendance is taken 
in both blocks will require a rotated schedule. In order to accommodate the full rotation schools 
may have multiple days. For example, a school that has eight rotations for their cycle to 
complete would need eight days for their rotated schedule. 

1.7.1 To Add schedule days: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Select the scenario you want to work with, and click the Days side-tab. 

4. On the Options menu, click Add. The Add Day dialog box appears: 
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5. In the Day count field, type the number of days in the schedule scenario. For example, if 
you are adding another day to a list of existing days, increase the number by one. The 
dialog box displays the appropriate number of rows, with each row representing one day. 

6. For each day, type an identifier in the Identifier column. 

Note: It is suggested using different identifiers for days and periods. For example, if you 
use letters for periods, use numbers for days. 

7. Type a name for each day in the Name column. 

8. Click Save. 

1.7.2 To Delete schedule days: 

If you rotated your schedule last year, you will want to DELETE the days that were added 
to accommodate your Rotation and reset the number of days, to what you schedule with.  
In the example below, this school rotates out the schedule to 8 Days, but schedules with 2 
Days.  Therefore, prior to starting scheduling, the number of Days needs to be adjusted 
back to 2. 

1. Select the scenario you want to work with, and click the Days side-tab. 

2. On the Options menu, click Add. The Add Day dialog box appears. 

3. In the Day count field, type the number of days in the schedule scenario. 

4. For each day, type an identifier in the Identifier column. 

Note: It is suggested using different identifiers for days and periods. For example, if you 
use letters for periods, use numbers for days. 

5. Type a name for each day in the Name column. 

6. Click Save. 

 

 

1.8 Periods 

Define the number of periods in your schedule. 

To define your periods: 

1. Log on to the Build view. 

2. Click the Scenario tab. 

3. Click the Periods side-tab. 
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4. On the Options menu, click Add. The Add Period dialog box appears: 

 

 

 

5. In the Period count field, type the number of periods in this schedule scenario. The 
dialog box displays the appropriate number of rows, with each row representing a 
period. 

6. For each period, type an identifier in the Identifier column. 

7. For each period, type a name in the Name column. 

8. Click Save. 

 

1.9 Bell Schedules 

During the 'prepare to build' schedule process, you might want to define your school’s bell 
schedules. 

Note: If your school uses more than one bell schedule during the same schedule day, you need 
to define bell schedules before you build. Otherwise, you can wait to define your bell schedules 
in the School view, after you commit your schedule. 

When you define your bell schedules, you define the start time and duration for each schedule 
period in your school. Then, when you validate your 'prepare to build' data, the schedule engine 
checks for any conflicts arising from the bell schedules. 

Not all schools need to define bell schedules. You need to define bell schedules for one or more 
of the following reasons: 

1. Your school has periods that overlap. For example, some schools have lunch spanning 
three   periods – 4, 5, and 6. You need to define the times of these periods to determine 
if and when there is a schedule conflict. 

2. Some schools have shorter periods in the afternoon (20 minutes) than in the morning 
(40 minutes). You need to define bell schedules to determine schedule conflicts for 
students. 

3. Grades in the same school might have different schedule shapes. For example, 5th, 6th, 
7th graders might operate with a 2-day/6-period schedule, and grades 8-12 might 
operate with a 2- day/4-period schedule. Because you can only define one schedule 
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shape per school, you can use bell schedules to differentiate between the two 
schedules. If you create more than one bell schedule for your school, you must use Bell 
Schedule rules to assign the appropriate bell schedules to rooms and courses. 

Note: If you want the build schedule engine to reference bell schedules when building the 
master schedule, select the Include in scheduling checkbox when defining bell schedules. 

Note: To copy bell schedules from a previous year, on the Options menu, click Copy From. 

 
To define bell schedules: 

1. Log on to the School view. 

2. Click the Schedule tab. 

3. Click the Structure side-tab, then click Bell Schedules. 

4. On the Options menu, click Add. The New Schedule Bell page appears: 

 

5. Type a unique identifier, name, and description for the bell schedule. 

6. Select the Include in scheduling? checkbox if you want the build engine to use this bell 
schedule to schedule sections to avoid conflicts. 

7. In the Number of days field, type the number of days in this bell schedule. 

8. At the Combine day’s field, to select multiple days that can feed to the particular bell 
schedule day. This allows different days' schedules to appear on one day on the fly 
without modifying the actual schedule.  

9. For each period, define the start time and duration. 

Note: The start time for each period does not have to be sequential like the period 
number order. This way, you can change the order of periods on the fly for a particular 
day without modifying the actual schedule.  
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Appendix A: Scenario Preferences Table 

Field Description 

To define basic preferences: 

Schedule expression format 

Select one of the following to determine how you want your days 
and periods to appear on the master and student schedules: 

 Period first 

 Day first 

For example, your schedule contains 7 periods (1-7) in a six-day 
cycle (A-F), and a section meets period 2 on day A. If you select 
to display 'period' first, the schedule expression will be 2(A). If 
you select to display 'day' first, the schedule expression will be 
A(2). 

Note: You might want to use one alpha character and one 
numeric to avoid confusion. For example, the schedule expression 
for Period 1, Day 1 would be 1(1). 

Use numeric section numbers 

Select this checkbox if you want the system to generate numeric 
section numbers. 

Note: If you select this option and later add a course section, the 
system will automatically populate the section number field with 
the next available number. 

Use study halls 
Select this checkbox if you want the system to schedule 
students in study halls when their schedule permits. 

Use rotation 

Select this checkbox if you want the system to consider the 
schedule rotation when building the master schedule to prevent 
certain rules from breaking, such as the teacher’s max-in-a-row 
value. 

Note: This checkbox does not trigger the rotation to happen. 

Use bell schedule 

Select this checkbox if you are going to use one or more bell 
schedules to create a schedule with this scenario. Rarely used. 

Note: If you plan to use more than one bell schedule, you need 
to define bell schedule rules to assign the appropriate bell 
schedules the appropriate rooms and courses. 

javascript:void(0);
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Field Description 

Control inclusion students 

Use this drop-down to select one of the following: 

 By ratio (%) to control the ratio of inclusion students in 

inclusion sections by a specific percentage. Type the 
percentage in the field. 

 By count to control the ratio of inclusion students in 

inclusion sections by specifying the exact number of 
inclusion students the system can schedule in each 
inclusion section. Type the number in the field. 

For example, a school can determine that inclusion sections can only 

contain four inclusion students (By count), or 10% of inclusion 

students (By ratio %). 

Notes: 

 If you do not define a number or percentage of inclusion 
students, you could inadvertently fill a class with all inclusion 
requests. 

 This works off the actual enrollment, not the enrollment max. 
For example, if the enrollment max is 30 and the inclusion 
ratio is 50% and 12 non-inclusion students are enrolled, a 
maximum of 12 inclusion students will be scheduled in the 
class. 

Include optional requests 

Select this checkbox if optional requests are considered primary 
requests in this scenario. Optional requests are primary 
requests that can be ignored under some conditions. 

Note: This option provides an easy way to remove particular 
requests without deleting them. For example, you might need to 
investigate decreasing your current 8-period day down to a 6-
period day. You could mark some requests as optional and then 
deselect this checkbox. 

Use reserve seats 

Select this checkbox if you want to enable reserve seating for all 
course sections. You can set aside a number of seats in a section 
on the Workspace, which you can fill after the schedule has been 
built. 

Use content term code 

Select this checkbox if you want the system to use the content 
term codes you define for sections when building this scenario. 

For example, maybe you want to allow students who fail part of 
a full-year course to retake that portion of it. 

Note: This field is related to the Content termcode on the student 
request. Remember that if a student fails first semester of a full-
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Field Description 

year course, they can request S1 only. The engine schedules the 
student in a section, but notes that the student is enrolled for the 
content term code only. Also, the student appears in the teacher’s 
gradebook for that term only.   
 
If you do not select this checkbox, the system ignores the Content 
termcode on the student's request, and schedules the student for the 

entire duration of the course. 

Show location, Show house, 
Show team, Show platoon, 
Show section type 

Select these checkboxes if you are going to use these student 
grouping options when building this scenario. The grouping 
fields (team, house, etc.) only appear on the Details page for a 
section on the Workspace tab if you select these checkboxes. 

Use student schedule weight 

Select this checkbox if this scenario uses student schedule 
weights. 

The system uses student scheduling weights when building and 
you have determined to close sections at maximum enrollment. 

By default, students have a schedule weight of 1. You might 
define a weight of 1.5 or 2 to determine specific students fill 
more than one seat due to his or her IEP requirements. 

Define student scheduling weights for each student in 
the student scheduling preferences. 

Note:You can determine that specific courses do not use schedule 
weights. 

To define advanced preferences: 

Engine processing time 
(seconds) 

Type the number of seconds you want the system to use to look 
ahead to teachers and rooms when trying to schedule a course. 

Use these fields when you are building the workspace and the 
scheduling engine is stopping repeatedly when it attempts to 
schedule courses because of teachers or rooms. 

Defining seconds in these fields allows the scheduling engine to 
look for unassigned teachers or rooms for the number of 
seconds you identify, instead of immediately presenting you with 
a conflict. 

Note: Entering a half-second adds significant processing time, and 

should help the system find the appropriate teachers or rooms. 

https://lt.myeducation.gov.bc.ca/AspenHelp/560/SI/EN_US/help/Content/Master_Schedule/Define_Specific_Information_for_Sections_Before_You_Build.htm
https://lt.myeducation.gov.bc.ca/AspenHelp/560/SI/EN_US/help/Content/Master_Schedule/Define_Specific_Information_for_Sections_Before_You_Build.htm
https://lt.myeducation.gov.bc.ca/AspenHelp/560/SI/EN_US/help/Content/Master_Schedule/Define_Student_Scheduling_Parameters.htm
https://lt.myeducation.gov.bc.ca/AspenHelp/560/SI/EN_US/help/Content/Master_Schedule/Define_Course_Scheduling_Parameters.htm
https://lt.myeducation.gov.bc.ca/AspenHelp/560/SI/EN_US/help/Content/Master_Schedule/Define_Course_Scheduling_Parameters.htm
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Field Description 

Max count for same validation 
Type the maximum number of times you want to view the same 
validation error when you validate your workspace. The default 
value for this field is 20. 

Use shared attributes: 

 course 

 staff 

 student 

 time structure 

If you select any of these checkboxes, the current scenario uses 
the same attributes shared by other scenarios of the same 
context year. The system applies any changes you make to 
these attributes to the other scenarios. 

If you do not select this checkbox, the current scenario has its 
own set of attributes. Any change made to the these attributes 
belongs to the current scenario only. 

Note: For example, if you share staff attributes and delete a staff 
member from one scenario, that person will automatically be 
deleted from any shared scenarios. Therefore, to minimize 
confusion and possible errors, it is recommended that you do not 
select these checkboxes. 

Relaxed room constraint, 
Order to relax room 
constraints, Relaxed room 
capacity reduction threshold 

Select the Relaxed room constraint checkbox if certain room 
constraints can be relaxed during the build process. For 
example, maybe you want to let teachers teach in their preferred 
room. However, after analyzing the schedule the system built, 
you realize you want to try letting the system relax this 
constraint and see the results. 

Below the Order to relax room constraints box, click Add to 
select from all types of room constraints you define, such 
as Capacity and Teacher’s preferred room. Select each 
constraint and click Up and Downto order the constraints from 
top to bottom; the scheduling engine relaxes the top constraint 
on the list first. 

If you select Room Capacity in the Order to relax room 
constraints box, in the Relaxed room capacity reduction 
threshold field, type the maximum percentage for rooms with 
less than desired capacity that can be used during the build 
process when necessary. 

Note: These options are usually used for adjusting the schedule 
later on in the process. 

Note: If a scenario does not use shared schedule attributes,  appears next to each of the schedule 
attributes to indicate they are privately owned by the current scenario. 
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Field Description 

General 

Schedule mode 

Select one of the following: 

 Elementary 

 Secondary 

 Both 

Elementary 
schedule grade 
level cut-off 

Type the grade at which the schedule shifts to Secondary mode. This only 
applies if you selected Both at the Schedule mode drop-down. 

Section number 
pad length 

Type the maximum number length for a section number. The default value is 
3. 

Note: Keep leading zeroes for sorting purposes. 

Shared build year 
scenario 

Select the build scenario that contains sections that will be taken by 
incoming secondary students. 

Allow build year 
request edits 

Select this checkbox to allow the school to manage requests for incoming 
students (based on a student's next school). 

Align teacher 
assignment with 
certification 

Select this checkbox to indicate if a teacher is certified to teach a course 
when creating teacher assignments. 

Student Subject Recommendation 

Do the following to customize how students select courses to request for the next year: 

Disable automatic 
recommendation 
acceptance 

Select this checkbox to stop Aspen from automatically creating requests for 
courses teachers recommend when the track selection that contains the 
course is set to 'force recommendations'. If you select this, students or 
counselors need to manually select the course recommended on the 
student’s Requests page to request it. 

For example, if your counselors review teacher recommendations for each 
student, selecting this checkbox allows them to determine if each 
recommendation is the best option before making it a request. 
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Field Description 

Subject selection 
fields 

Click  to select any additional fields to display in the Course Selection 
pick list students use to select courses to request. 

Teacher Recommendation 

Do the following to customize how teachers select courses to recommend for their current students to 
take next year: 

Show 
recommendations 
in School view 

Select this checkbox to display teacher recommendations on 
the Grades tab, Grade Input side-tab in the School view. 

Note: Recommendations in the School view are read-only. 

Enforce 
recommendation 
code match 

Select this checkbox to force the scheduler to match any build courses with a 
matching recommendation code. If the checkbox is not selected, the scheduler 
looks for a matching department code. 

Teacher 
recommendation 
fields 

Click  to select additional fields to be included in the pick list teachers 
use to select the courses to recommend for students. 

Student Schedules 

Student schedule 
sort order 

Type the student schedule sort order using the Java name for fields. The 
system uses this order to sort the student schedule list in both the School 
and Build views. 

The default value 
is scheduleDisplay,termView,masterSchedule.scheduleTrackId, 
masterSchedule.courseView. These values are ones found in 
the JavaName field for the field in the Data Dictionary. 

Student schedule 
matrix cell 

Type the fields used in the student schedule matrix. 

Student Schedule Workspace 

Student schedule 
fields 

Type the columns to appear on the student schedule workspace you use to 
manage student schedules. 

Master select 
fields 

Type the columns that appear in the master schedule pop-up when you add 
a section to a student's schedule on the student schedule workspace. 
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Field Description 

Allow future 
add/drop 

Select this checkbox to be able to enter a future effective date when adding 
or dropping student course sections on the student schedule workspace 
(School view, Student > Schedule > Workspace). These changes will be 
reflected in the student’s schedule on the effective date. 

If you do not select this checkbox, the Pending student schedule change 
fields preference will not be enabled. 

Allow past add/drop 

Select this checkbox to be able to enter a past effective date when adding or 
dropping student course sections on the student schedule workspace 
(School view, Student > Schedule > Workspace). These changes will be 
reflected in the student’s schedule on the effective date. 

If this checkbox is not selected, the school administrator cannot specify a 
past date when posting Student Schedule changes from the student 
schedule workspace. 

Pending student 
schedule change 
fields 

This preference works in conjunction with Allow future add/drop. If you did 
not select that checkbox, this field is ignored. 

If you selected Allow future add/drop, enter the fields you want to appear 
in the Pending Student Schedule Changes section of the student schedule 
workspace (School view, Student > Schedule > Workspace). 

Align add/drop 
date window 
(days) 

Type the number of days after the school year starts that student schedule 
adds/drops need to be aligned. 

 

For additional preferences, click the Advanced sub-tab: 
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Use the following table to enter information in the fields: 

Field Description 

Miscellaneous 

Pattern day IDs Type the default day for school patterns. The system default value is A-L. 

Pattern period IDs 
Type the default period IDs for school patterns. The system default 

value is 1-20. 

Schedule on 
client machine 

Select this checkbox to run the scheduling engine on the user’s workstation 
instead of the server. 

Notes: 

 The primary purpose of this feature is to conserve server processing 
resources. If many users are running builds and loads at the same time, 
server performance can be affected. Running the engine locally leverages 
the workstation’s processing power to reduce the load on the server. 

 If you select this checkbox, the user who builds the schedule must specify 
where the scheduling engine should write files to when they set their user 
preferences (Build view, Set Preferences > Schedule). 

Number of 
sections deleted 
with warning 

Type the minimum number of sections being deleted that will prompt a system 
warning upon deletion. 

 


